Bug 1278376 - [admin portal] Upgrade Host dialog contains in iso list currently installed version of hypervisor
[admin portal] Upgrade Host dialog contains in iso list currently installed v...
Status: CLOSED DUPLICATE of bug 1078154
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
Unspecified Unspecified
medium Severity low (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Moti Asayag
Pavel Stehlik
Depends On:
  Show dependency treegraph
Reported: 2015-11-05 06:14 EST by Jiri Belka
Modified: 2016-02-10 14:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-11-12 06:29:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
masayag: ovirt‑4.0.0?
rule-engine: planning_ack?
masayag: devel_ack+
rule-engine: testing_ack?

Attachments (Terms of Use)
upgrade host dialog (140.51 KB, image/png)
2015-11-05 06:14 EST, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2015-11-05 06:14:23 EST
Created attachment 1090022 [details]
upgrade host dialog

Description of problem:

Upgrade Host dialog contains in iso list currently installed version, based on comment in  https://bugzilla.redhat.com/show_bug.cgi?id=1191155#c4, this is odd.

see screenshot

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. engine 3.6
2. install hypervisor with some version
3. install newer hypervisor rpm onto engine server, restart engine
4. observe Upgrade Host dialog in admin portal and 'ISO name' list

Actual results:
ISO name list contains currently installed hypervisor version and this is odd as the dialog is called Upgrade Host (thus not logical to list currently installed version as proposition for upgrade)

Expected results:
only newer versions should be listed to it is upgrade in reality

Additional info:
Comment 1 Moti Asayag 2015-11-12 06:29:18 EST
Filtering the suggested ISOs list will be handled by Bug 1078154

*** This bug has been marked as a duplicate of bug 1078154 ***

Note You need to log in before you can comment on or make changes to this bug.