Bug 1278400 - Openstack instances are missing power actions when selected from the instances list
Openstack instances are missing power actions when selected from the instance...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Shveta
Shveta
openstack
:
Depends On:
Blocks: 1289639
  Show dependency treegraph
 
Reported: 2015-11-05 06:57 EST by Marius Cornea
Modified: 2016-06-29 11:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289639 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:02:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
power states (140.30 KB, image/png)
2016-06-01 00:59 EDT, Shveta
no flags Details

  None (edit)
Description Marius Cornea 2015-11-05 06:57:16 EST
Description of problem:
The Openstack instances are missing power actions when selected from the instances list - they are only showing the Terminate action.

When going to instance details the Power menu shows additional actions.

Version-Release number of selected component (if applicable):
5.5.0.9-beta2.20151102161742_5530c9a

How reproducible:
100%

Steps to Reproduce:
1. Add Openstack Cloud provider with running instances
2. Go to Cloud -> Instances
3. List all instances of the cloud provider
4. Click on the check box associated to one of the instances
5. Go to the Power menu

Actual results:
Only the Terminate action shows up.

Expected results:
A complete set of actions shows up: Stop, Suspend, Soft Reboot, Hard Reboot, Terminate.
Comment 4 Ladislav Smola 2015-11-06 04:04:34 EST
Can anybody from UI team give me some insight why this is missing? I guess it's because of filtering of actions based on selected instances? 

Meaning when you select only active instances, you will have appropriate actions, but what happens when you select non active? If we would show only possible actions, we would show only Terminate action at this point. But that would require some hook on select of each item, which is not there, right?

@Dan can you answer? If it is how I think it is, I think this should turn into generic RFE for all tables, right? That would mean UI team will be more appropriate for solving it.
Comment 9 Ladislav Smola 2015-11-13 03:35:17 EST
upstream fix https://github.com/ManageIQ/manageiq/pull/5423
Comment 12 CFME Bot 2016-01-11 12:36:34 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ada33f332d4f6178363fa1fb12e8fca532c35973

commit ada33f332d4f6178363fa1fb12e8fca532c35973
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Fri Nov 13 09:32:56 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Mon Jan 11 17:20:58 2016 +0100

    Cloud Vms add missing list actions
    
    We should have all actions shown in list. So the list of actions
    should be the same as list in VM detail.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1278400
    
    Clean cherry-pick of:
    https://github.com/ManageIQ/manageiq/pull/5423
    
    5.5.z BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1289639

 product/toolbars/vm_clouds_center_tb.yaml | 76 ++++++++++++++++++++++++++++++-
 1 file changed, 75 insertions(+), 1 deletion(-)
Comment 13 CFME Bot 2016-01-11 12:36:44 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=98569e8d3551beb7d22d89cb6601d113be572014

commit 98569e8d3551beb7d22d89cb6601d113be572014
Merge: c3e68cb ada33f3
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Jan 11 12:09:27 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Jan 11 12:09:27 2016 -0500

    Merge branch 'bz1278400' into '5.5.z'
    
    Cloud Vms add missing list actions
    
    We should have all actions shown in list. So the list of actions
    should be the same as list in VM detail.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1278400
    
    Clean cherry-pick of:
    https://github.com/ManageIQ/manageiq/pull/5423
    
    5.5.z BZ
    https://bugzilla.redhat.com/show_bug.cgi?id=1289639
    
    See merge request !692

 product/toolbars/vm_clouds_center_tb.yaml | 76 ++++++++++++++++++++++++++++++-
 1 file changed, 75 insertions(+), 1 deletion(-)
Comment 14 CFME Bot 2016-01-12 10:05:49 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/32e6b262c709af3e24150039b5d4ad80aaf1c4ea

commit 32e6b262c709af3e24150039b5d4ad80aaf1c4ea
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Fri Nov 13 09:32:56 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Mon Jan 11 11:32:48 2016 +0100

    Cloud Vms add missing list actions
    
    We should have all actions shown in list. So the list of actions
    should be the same as list in VM detail.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1278400

 product/toolbars/vm_clouds_center_tb.yaml | 76 ++++++++++++++++++++++++++++++-
 1 file changed, 75 insertions(+), 1 deletion(-)
Comment 15 Shveta 2016-06-01 00:59 EDT
Created attachment 1163491 [details]
power states

Verified in 5.6.0.8-rc1.20160524155303_f2a5a50
Comment 17 errata-xmlrpc 2016-06-29 11:02:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.