Bug 1278468 - rpcbind.socket not started after initial installation
rpcbind.socket not started after initial installation
Status: CLOSED DUPLICATE of bug 1303751
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpcbind (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Steve Dickson
Filesystem QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 09:48 EST by Laurent Bigonville
Modified: 2016-04-09 10:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-09 10:42:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laurent Bigonville 2015-11-05 09:48:16 EST
Description of problem:
When installing the rpcbind package, the rpcbind.socket unit is being enabled (via systemctl enable rpcbind.service call) but the socket itself is not started. That means that trying to mount a NFS 3 share just after that will fail because rpc-statd will fail to start because rpcbind is not running. After a reboot, the NFS share is mounted.

Version-Release number of selected component (if applicable):
rpcbind-0.2.0-26.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. install nfs-utils package
2. try to mount an nfs3 share
3. it fails to mount and rpc-statd is complaining that rpcbind is not running

Actual results:
NFS share not mounted just after installing nfs-utils/rpcbind package

Expected results:
NFS is mounted properly

Additional info:
Comment 2 Steve Dickson 2016-04-09 10:42:26 EDT

*** This bug has been marked as a duplicate of bug 1303751 ***

Note You need to log in before you can comment on or make changes to this bug.