Bug 1303751 - Upgrade of rpcbind does not restart rpcbind.socket
Upgrade of rpcbind does not restart rpcbind.socket
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpcbind (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Steve Dickson
Yongcheng Yang
Marie Dolezelova
: ZStream
: 1278468 (view as bug list)
Depends On:
Blocks: 1203710 1313485 1295577 1306824 1325769
  Show dependency treegraph
 
Reported: 2016-02-01 15:27 EST by Frank Sorenson
Modified: 2016-11-03 22:10 EDT (History)
12 users (show)

See Also:
Fixed In Version: rpcbind-0.2.0-35.el7
Doc Type: Bug Fix
Doc Text:
After an upgrage of the rpcbind packages, the automounted file systems became inaccessible, which also caused an unexpected termination of running applications dependant on these file systems. The provided patch ensures that the rpcbind.socket is restarted. As a result, rpcinfo is able to connect to rpcbind locally, and automounted file systems are accessible as expected.
Story Points: ---
Clone Of:
: 1306824 1325769 (view as bug list)
Environment:
Last Closed: 2016-11-03 22:10:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Sorenson 2016-02-01 15:27:00 EST
Description of problem:

When upgrading rpcbind, rpcbind.socket is not restarted, so rpcbind cannot be queried locally


Version-Release number of selected component (if applicable):

rpcbind-0.2.0-32.el7.x86_64.rpm


How reproducible:

see below


Steps to Reproduce:

begin with lower-version rpcbind

# rpm -qa rpcbind:
rpcbind-0.2.0-26.el7.x86_64

verify rpcinfo works:
# rpcinfo -p
   program vers proto   port  service
    100000    4   tcp    111  portmapper
...

upgrade rpcinfo:
# rpm -Fvh rpcbind-0.2.0-34.el7.x86_64.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:rpcbind-0.2.0-34.el7             ################################# [ 50%]
Cleaning up / removing...
   2:rpcbind-0.2.0-26.el7             ################################# [100%]

test rpcinfo:
# rpcinfo -p
rpcinfo: can't contact portmapper: RPC: Remote system error - Connection refused


Actual results:

rpcinfo is unable to connect to rpcbind locally


Expected results:

rpcinfo continues to work after upgrade


Additional info:

rpcinfo is connecting using the socket at /var/run/rpcbind.sock:

# strace -fttT -etrace=connect rpcinfo -p
20:14:59.801429 connect(4, {sa_family=AF_LOCAL, sun_path="/var/run/rpcbind.sock"}, 23) = -1 ECONNREFUSED (Connection refused) <0.000044>
rpcinfo: can't contact portmapper: RPC: Remote system error - Connection refused
20:14:59.802120 +++ exited with 1 +++


restarting rpcbind.socket makes things work again:

# systemctl restart rpcbind.socket

# strace -fttT -etrace=connect rpcinfo -p
20:15:19.438648 connect(4, {sa_family=AF_LOCAL, sun_path="/var/run/rpcbind.sock"}, 23) = 0 <0.000188>
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    4   tcp    111  portmapper
...
Comment 5 Steve Dickson 2016-02-11 14:26:54 EST
This is the needed patch which also needs to go into fedora

diff --git a/rpcbind.spec b/rpcbind.spec
index 92824f0..8389f1a 100644
--- a/rpcbind.spec
+++ b/rpcbind.spec
@@ -157,8 +157,9 @@ fi
 /sbin/chkconfig --del rpcbind >/dev/null 2>&1 || :
 /bin/systemctl try-restart rpcbind.service >/dev/null 2>&1 || :
 
-%triggerun -- rpcbind > 0.2.0-26
+%triggerin -- rpcbind > 0.2.0-26
 /bin/systemctl enable rpcbind.socket >/dev/null 2>&1 || :
+/bin/systemctl restart rpcbind.socket >/dev/null 2>&1 || :
 
 %triggerpostun -- rpcbind < -2.2.0-29
 [ ! -d /run/rpcbind ] && mkdir /run/rpcbind || :
Comment 10 Steve Dickson 2016-04-04 16:49:15 EDT
Fedora commit:

ommit c0f80c5a6720c12c710e444714be7eae388c1460
Author: Steve Dickson <steved@redhat.com>
Date:   Mon Apr 4 11:01:08 2016 -0400

    Restart rpcbind.socket on restarts (bz 1306824)
Comment 11 Steve Dickson 2016-04-09 10:42:26 EDT
*** Bug 1278468 has been marked as a duplicate of this bug. ***
Comment 14 Joseph Kachuck 2016-04-11 13:42:26 EDT
Hello,

This bug has been copied as 7.2 z-stream (EUS) bug #1325769 

Thank You
Joe Kachuck
Comment 17 errata-xmlrpc 2016-11-03 22:10:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2274.html

Note You need to log in before you can comment on or make changes to this bug.