Bug 1278519 - Netconsole cannot resolve the syslog server address if it is only included in the /etc/hosts file
Netconsole cannot resolve the syslog server address if it is only included in...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Kaspar [Dee'Kej]
Jan Ščotka
Clayton Spicer
: FastFix, Patch, Reproducer
Depends On:
Blocks: 1269194 1356056 1278521 1398675
  Show dependency treegraph
 
Reported: 2015-11-05 11:59 EST by Raul Mahiques
Modified: 2017-03-21 07:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: initscripts-9.03.54-1
Doc Type: Release Note
Doc Text:
The *netconsole* utility now launches correctly Previously, if `nameserver` address lines were not present in the `/etc/resolv.conf` file, launching *netconsole* sometimes resulted in an error and *netconsole* did not start. The _initscripts_ package has been updated, and *netconsole* now starts correctly in this situation.
Story Points: ---
Clone Of:
: 1278521 1398675 (view as bug list)
Environment:
Last Closed: 2017-03-21 07:52:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch file, replaces command 'hosts' with 'getent' (750 bytes, patch)
2015-11-05 11:59 EST, Raul Mahiques
no flags Details | Diff

  None (edit)
Description Raul Mahiques 2015-11-05 11:59:35 EST
Created attachment 1090294 [details]
Patch file, replaces command 'hosts' with 'getent'

Description of problem:
netconsole script fails if the syslog address is not available via a DNS server, this prevents netconsole to work with hosts that have not access to a DNS server and have the hostsnames hardcoded in /etc/hosts.
This applies for RHEL7 releases too

Version-Release number of selected component (if applicable):
Up to initscripts-9.49.24-1.el7

How reproducible:
Always


Steps to Reproduce:
1. Remove the nameserver lines from /etc/resolv.conf
2. add the syslog server IP and name to /etc/hosts
3. run the netconsole.
4. despite we can resolve the syslog server name it will fail with an missleading message:
"Server address not specified in /etc/sysconfig/netconsole'


Actual results:
"Server address not specified in /etc/sysconfig/netconsole'

Expected results:
Starts normally

Additional info:
A patch for this is provided
Comment 3 David Kaspar [Dee'Kej] 2016-10-28 06:39:58 EDT
I have modified the patch from Raul, to avoid some possible issues in the future.

The patch has been submitted for review:
https://github.com/fedora-sysv/initscripts/pull/18
Comment 5 David Kaspar [Dee'Kej] 2016-11-07 08:54:07 EST
Commit accepted:
https://github.com/fedora-sysv/initscripts/commit/98037643411b5331a483d58
Comment 10 errata-xmlrpc 2017-03-21 07:52:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0786.html

Note You need to log in before you can comment on or make changes to this bug.