Bug 1278521 - Netconsole cannot resolve the syslog server address if it is only included in the /etc/hosts file
Netconsole cannot resolve the syslog server address if it is only included in...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts (Show other bugs)
7.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Kaspar [Dee'Kej]
Leos Pol
Filip Hanzelka
: Patch, Reproducer
: 1398675 (view as bug list)
Depends On: 1278519 1392766
Blocks: 1298243 1393867
  Show dependency treegraph
 
Reported: 2015-11-05 12:01 EST by Raul Mahiques
Modified: 2017-08-01 03:29 EDT (History)
4 users (show)

See Also:
Fixed In Version: initscripts-9.49.38-1.el7
Doc Type: Release Note
Doc Text:
The *netconsole* utility now launches correctly Previously, if `nameserver` address lines were not present in the `/etc/resolv.conf` file, launching *netconsole* sometimes resulted in an error and *netconsole* did not start. The _initscripts_ package has been updated, and *netconsole* now starts correctly in this situation.
Story Points: ---
Clone Of: 1278519
Environment:
Last Closed: 2017-08-01 03:29:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch file, replaces command 'hosts' with 'getent' (750 bytes, patch)
2015-11-05 12:01 EST, Raul Mahiques
no flags Details | Diff

  None (edit)
Description Raul Mahiques 2015-11-05 12:01:12 EST
Created attachment 1090295 [details]
Patch file, replaces command 'hosts' with 'getent'

+++ This bug was initially created as a clone of Bug #1278519 +++

Description of problem:
netconsole script fails if the syslog address is not available via a DNS server, this prevents netconsole to work with hosts that have not access to a DNS server and have the hostsnames hardcoded in /etc/hosts.
This applies for RHEL7 releases too

Version-Release number of selected component (if applicable):
Up to initscripts-9.49.24-1.el7

How reproducible:
Always


Steps to Reproduce:
1. Remove the nameserver lines from /etc/resolv.conf
2. add the syslog server IP and name to /etc/hosts
3. run the netconsole.
4. despite we can resolve the syslog server name it will fail with an missleading message:
"Server address not specified in /etc/sysconfig/netconsole'


Actual results:
"Server address not specified in /etc/sysconfig/netconsole'

Expected results:
Starts normally

Additional info:
A patch for this is provided
Comment 3 Raul Mahiques 2016-02-26 10:05:56 EST
In the patch provided, please change the following:


-if ( grep -i 'IPV6INIT=yes' /etc/sysconfig/network &>/dev/null )
+if [ "$(</proc/sys/net/ipv6/conf/all/disable_ipv6)" == '0' ]
Comment 8 David Kaspar [Dee'Kej] 2017-03-24 11:00:56 EDT
*** Bug 1398675 has been marked as a duplicate of this bug. ***
Comment 13 errata-xmlrpc 2017-08-01 03:29:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2286

Note You need to log in before you can comment on or make changes to this bug.