Bug 1278523 - Crash saving opened PDF
Crash saving opened PDF
Status: CLOSED DUPLICATE of bug 1278717
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Catanzaro
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 12:04 EST by Jacobo Aragunde
Modified: 2015-11-06 04:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-06 04:31:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacobo Aragunde 2015-11-05 12:04:35 EST
Description of problem:
Epiphany crashes when saving a PDF that has been opened with the Evince document viewer plugin.

Version-Release number of selected component (if applicable):
3.16.3-2.fc22

How reproducible:
Always.

Steps to Reproduce:
1. Open any PDF document with the default document viewer plugin provided by Evince.
2. Press Ctrl+S or click on Epiphany menu button -> Save as...
3. Select some destination directory for the file.

Actual results:
Browser crashes. A 0-byte file is created at the destination directory.

Expected results:
File is properly saved.

Additional info:
Problem seems to be in Epiphany and not in the plugin. The "download" button in the plugin works properly.
Comment 1 Michael Catanzaro 2015-11-05 13:46:44 EST
Ah, it's better to report bugs directly to bugzilla.webkit.org or bugzilla.gnome.org if you're going to report manually... but if you use ABRT (the "Problem Reporting" application we install by default) to report the crashes, then the bugs will be created here, and I will move those upstream (eventually :).

If you do report crashes manually, please do provide a backtrace from gdb. Easiest way is to just use ABRT!
Comment 2 Jacobo Aragunde 2015-11-06 04:31:01 EST
Totally forgot about ABRT. I've used it to report a new entry, it's at bug #1278717.

Closing this one as dupe.

*** This bug has been marked as a duplicate of bug 1278717 ***

Note You need to log in before you can comment on or make changes to this bug.