Bug 1278717 - [abrt] epiphany-runtime: web_resource_get_data_cb(): epiphany killed by SIGSEGV
[abrt] epiphany-runtime: web_resource_get_data_cb(): epiphany killed by SIGSEGV
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: webkitgtk4 (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Popela
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:709eb088fe5e25ed7a5bfda7425...
:
: 1278523 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 04:24 EST by Jacobo Aragunde
Modified: 2015-11-06 13:35 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-06 13:35:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (65.89 KB, text/plain)
2015-11-06 04:24 EST, Jacobo Aragunde
no flags Details
File: cgroup (190 bytes, text/plain)
2015-11-06 04:25 EST, Jacobo Aragunde
no flags Details
File: core_backtrace (6.86 KB, text/plain)
2015-11-06 04:25 EST, Jacobo Aragunde
no flags Details
File: dso_list (16.22 KB, text/plain)
2015-11-06 04:25 EST, Jacobo Aragunde
no flags Details
File: environ (2.06 KB, text/plain)
2015-11-06 04:25 EST, Jacobo Aragunde
no flags Details
File: limits (1.29 KB, text/plain)
2015-11-06 04:25 EST, Jacobo Aragunde
no flags Details
File: maps (81.83 KB, text/plain)
2015-11-06 04:25 EST, Jacobo Aragunde
no flags Details
File: mountinfo (3.38 KB, text/plain)
2015-11-06 04:25 EST, Jacobo Aragunde
no flags Details
File: namespaces (85 bytes, text/plain)
2015-11-06 04:25 EST, Jacobo Aragunde
no flags Details
File: open_fds (2.94 KB, text/plain)
2015-11-06 04:25 EST, Jacobo Aragunde
no flags Details
File: proc_pid_status (1013 bytes, text/plain)
2015-11-06 04:25 EST, Jacobo Aragunde
no flags Details
File: var_log_messages (403 bytes, text/plain)
2015-11-06 04:25 EST, Jacobo Aragunde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 746737 None None None Never

  None (edit)
Description Jacobo Aragunde 2015-11-06 04:24:53 EST
Description of problem:
1. Open any PDF document with the default document viewer plugin provided by Evince.
2. Press Ctrl+S or click on Epiphany menu button -> Save as...
3. Select some destination directory for the file.

Version-Release number of selected component:
epiphany-runtime-3.16.3-2.fc22

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        epiphany
crash_function: web_resource_get_data_cb
executable:     /usr/bin/epiphany
global_pid:     4989
kernel:         4.2.3-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 web_resource_get_data_cb at ephy-web-view.c:2946
 #1 g_task_return_now at gtask.c:1088
 #2 g_task_return at gtask.c:1146
 #3 operator() at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/UIProcess/API/gtk/WebKitWebResource.cpp:371
 #4 std::_Function_handler<void(API::Data*, WebKit::CallbackBase::Error), webkit_web_resource_get_data(WebKitWebResource*, GCancellable*, GAsyncReadyCallback, gpointer)::<lambda(API::Data*, WebKit::CallbackBase::Error)> >::_M_invoke(const std::_Any_data &, <unknown type in /usr/lib/debug/usr/lib64/libwebkit2gtk-4.0.so.37.6.8.debug, CU 0xa2acb55, DIE 0xa33712e>, <unknown type in /usr/lib/debug/usr/lib64/libwebkit2gtk-4.0.so.37.6.8.debug, CU 0xa2acb55, DIE 0xa337133>) at /usr/include/c++/5.1.1/functional:1871
 #5 operator() at /usr/include/c++/5.1.1/functional:2271
 #6 performCallbackWithReturnValue at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/UIProcess/GenericCallback.h:112
 #7 WebKit::WebPageProxy::dataCallback at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/UIProcess/WebPageProxy.cpp:4474
 #8 callMemberFunctionImpl<WebKit::WebPageProxy, void (WebKit::WebPageProxy::*)(IPC::DataReference const&, unsigned long), std::tuple<IPC::DataReference, unsigned long>, 0ul, 1ul> at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/Platform/IPC/HandleMessage.h:16
 #9 callMemberFunction<WebKit::WebPageProxy, void (WebKit::WebPageProxy::*)(IPC::DataReference const&, unsigned long), std::tuple<IPC::DataReference, unsigned long>, std::make_index_sequence<2ul> > at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/Platform/IPC/HandleMessage.h:22

Potential duplicate: bug 1089257
Comment 1 Jacobo Aragunde 2015-11-06 04:24:59 EST
Created attachment 1090532 [details]
File: backtrace
Comment 2 Jacobo Aragunde 2015-11-06 04:25:01 EST
Created attachment 1090533 [details]
File: cgroup
Comment 3 Jacobo Aragunde 2015-11-06 04:25:02 EST
Created attachment 1090534 [details]
File: core_backtrace
Comment 4 Jacobo Aragunde 2015-11-06 04:25:04 EST
Created attachment 1090535 [details]
File: dso_list
Comment 5 Jacobo Aragunde 2015-11-06 04:25:05 EST
Created attachment 1090536 [details]
File: environ
Comment 6 Jacobo Aragunde 2015-11-06 04:25:07 EST
Created attachment 1090537 [details]
File: limits
Comment 7 Jacobo Aragunde 2015-11-06 04:25:10 EST
Created attachment 1090538 [details]
File: maps
Comment 8 Jacobo Aragunde 2015-11-06 04:25:11 EST
Created attachment 1090539 [details]
File: mountinfo
Comment 9 Jacobo Aragunde 2015-11-06 04:25:13 EST
Created attachment 1090540 [details]
File: namespaces
Comment 10 Jacobo Aragunde 2015-11-06 04:25:14 EST
Created attachment 1090541 [details]
File: open_fds
Comment 11 Jacobo Aragunde 2015-11-06 04:25:16 EST
Created attachment 1090542 [details]
File: proc_pid_status
Comment 12 Jacobo Aragunde 2015-11-06 04:25:17 EST
Created attachment 1090543 [details]
File: var_log_messages
Comment 13 Jacobo Aragunde 2015-11-06 04:26:49 EST
Additional info:
* Problem seems to be in Epiphany and not in the plugin. The "download" button in the plugin works properly.
* A 0-byte file is created at the destination directory.
Comment 14 Jacobo Aragunde 2015-11-06 04:31:01 EST
*** Bug 1278523 has been marked as a duplicate of this bug. ***
Comment 15 Michael Catanzaro 2015-11-06 13:32:52 EST
Perfect bug report, gracias!

Note You need to log in before you can comment on or make changes to this bug.