Bug 127862 - INSTALL: kernel BUG at kernel/workqueue.c:104
INSTALL: kernel BUG at kernel/workqueue.c:104
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 137273 (view as bug list)
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-07-14 15:53 EDT by Ian Pilcher
Modified: 2015-01-04 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-31 18:07:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
FC3t2 installation BUG test (1.07 KB, text/plain)
2004-10-07 20:14 EDT, Ian Pilcher
no flags Details
BUG output from FC3rc2 (1.11 KB, text/plain)
2004-10-27 16:33 EDT, Ian Pilcher
no flags Details
serial console capture from FC3rc2 (19.51 KB, text/plain)
2004-10-27 17:28 EDT, Ian Pilcher
no flags Details

  None (edit)
Description Ian Pilcher 2004-07-14 15:53:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2

Description of problem:
Trying to install Fedora Core 3 test 1 on my Abit VP6-based system.
The following kernel BUG occurs right after I confirm my package
selections.


------------[ cut here ]------------
kernel BUG at kernel/workqueue.c:104!
invalid operand: 0000 [#2]
Modules linked in: parport_pc parport dm_mod xfs jfs reiserfs ext3 jbd
msdos rai
d6 raid5 xor raid1 raid0 8139too mii uhci_hcd sr_mod sd_mod scsi_mod
floppy loop
 nfs lockd sunrpc vfat fat cramfs vga16fb vgastate
CPU:    0
EIP:    0060:[<c0130cb4>]    Not tainted
EFLAGS: 00210202   (2.6.7-1.478)
EIP is at queue_work+0x17/0x2f
eax: c2187620   ebx: f7d22148   ecx: 00000000   edx: c218761c
esi: c02328e6   edi: c03424a0   ebp: c03bffd0   esp: c03bffc8
ds: 007b   es: 007b   ss: 0068
Process anaconda (pid: 429, threadinfo=c03bf000 task=f6fef970)
Stack: c21874e4 c012831f c03bffd0 c03bffd0 00000000 00000011 c03e4ca8
0000000a
       00000000 c0124185 f6c15e44 00200046 c03c0000 c0108d17
Call Trace:
Stack pointer is garbage, not printing trace
Code: 0f 0b 68 00 3f 8a 30 c0 89 d8 e8 e5 fe ff ff b9 01 00 00 00
 <0>Kernel panic: Fatal exception in interrupt
In interrupt handler - not syncing


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Attempt to install Fedora Core 3 test 1 on an Abit VP6-based system.
2.
3.
    

Additional info:
Comment 1 Ian Pilcher 2004-10-07 20:14:07 EDT
Created attachment 104917 [details]
FC3t2 installation BUG test

This bug is still present in test 2.
Comment 2 Ian Pilcher 2004-10-08 13:00:41 EDT
I've managed to work around this BUG by disabling the drives that
contain my software RAID partitions (hde=none hdg=none hdi=none
hdk=none) and installing a minimal system on hda.  hda is attached to
the built in VIA controller on the VP6; hde-hdk are attached to a
couple of Maxtor-branded Promise PDC20269 (Ultra133TX2) controllers. 
Note that simply installing to a partition on /dev/hda wasn't
sufficient, possibly because of the swap "filesystem" on /dev/md2.

It's only a guess, but I think that the BUG may be triggered when
Anaconda tries to start a software RAID device.  queue_work seems to
be involved in starting new kernel threads, and this is the most only
reason I can come up with that a new kernel thread would be created at
this point in the installation process.
Comment 3 Ian Pilcher 2004-10-12 01:36:42 EDT
Still there in test 3 also.
Comment 4 Ian Pilcher 2004-10-24 13:54:50 EDT
Still present in RC1.
Comment 5 Ian Pilcher 2004-10-27 15:30:34 EDT
Still present in RC2.
Comment 6 Dave Jones 2004-10-27 15:50:05 EDT
is it the exact same trace in RC2 ? No further information, like a stack trace ?
Comment 7 Ian Pilcher 2004-10-27 16:33:41 EDT
Created attachment 105866 [details]
BUG output from FC3rc2
Comment 8 Ian Pilcher 2004-10-27 17:28:59 EDT
Created attachment 105869 [details]
serial console capture from FC3rc2

I got lazy and used a serial console to capture the BUG from FC3rc2.  Scanning
through the output I noticed that there is a kernel OOPS which I never saw
before.  It occurs during the "Searching for Fedora Core installations..."
phase.
Comment 9 Elliot Lee 2004-10-29 13:24:00 EDT
Please try kernel-2.6.9-1.649 - it supposedly has a fix for the oops
at least.
Comment 10 Dave Jones 2004-10-29 14:23:41 EDT
*** Bug 137273 has been marked as a duplicate of this bug. ***
Comment 11 Ian Pilcher 2004-10-29 15:18:49 EDT
Where can I find 2.6.9-1.649?
Comment 12 Ian Pilcher 2004-10-31 18:07:54 EST
Never mind.  RC5 successfully installs -- no OOPS or BUG.

Note You need to log in before you can comment on or make changes to this bug.