Bug 127863 - FC3T1: system-config-soundcard failed to test sound on Dell P650n
Summary: FC3T1: system-config-soundcard failed to test sound on Dell P650n
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-soundcard   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact:
URL:
Whiteboard:
Keywords:
: 133596 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-14 20:02 UTC by Thomas Chung
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 1.2.11-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-09 11:04:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Chung 2004-07-14 20:02:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
During the firstboot, system-config-soundcard failed to test sound on
Dell Precision 650n (integrated AC'97 Audio Controller)

Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.8-1

How reproducible:
Always

Steps to Reproduce:
1. Install a fresh FC3 Test 1
2. Follow Firstboot steps
3. system-config-soundcard failed to test sound on Dell P650n due to
it set PCM-2 channel to 0 by default. No sound can be heard during the
sound testing.
    

Actual Results:  It was necessary to run volume-control and set PCM-2
channel to about 80% in order to hear test sound for
system-config-soundcard.


Expected Results:  It should have set PCM-2 channel to about 80%
during the firstboot step in order to hear test sound for
system-config-soundcard.

Additional info:

Comment 1 Bastien Nocera 2004-07-21 16:53:40 UTC
This line in the /etc/modprobe.conf should have unmuted the sound:
install sound-slot-0 /sbin/modprobe --ignore-install sound-slot-0 && {
/bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :; }

Could you try:
1) Remove the driver from the kernel with rmmod
2) Remove (or move away) /etc/.aumixrc
3) Launch "modprobe sound-slot-0" and check that the mixers are unmuted

Comment 2 Thomas Chung 2004-07-23 23:57:16 UTC
It seems the actual entries in /etc/modprobe.conf is different than
what you've described.

Please see modprobe.conf from:
http://fedoranews.org/tchung/fc3-test1/bug/

Notice, lsmod shows 'snd_intel8x0' but modprobe.conf shows
'snd-intel8x0'   Could this be a typo?

Also it did not create /etc/.aumixrc file since it's using
/usr/sbin/alsactl instead of /bin/aumix-minimal

I've also included some screenshots which shows,
'volume-control-tab1.png' PCM-2 channel is set to 0 by default and
this is why I could not hear any test sound during the firstboot steps.  

Comment 3 Bastien Nocera 2004-09-30 23:52:42 UTC
I've added some code to unmute PCM-2 as well. Will be in rawhide soon
(ie. after the freeze).

(you can try and copy the code that sets Master and PCM, and add a
"PCM-2" case yourself to soundcardBackend.py, if you want to test this).

Comment 4 Bastien Nocera 2004-10-03 11:38:35 UTC
*** Bug 133596 has been marked as a duplicate of this bug. ***

Comment 5 Bastien Nocera 2005-05-09 11:04:19 UTC
Fixed in 1.2.11-2.


Note You need to log in before you can comment on or make changes to this bug.