Bug 1278640 - [New] - Files in a tiered volume gets promoted when bitd signs them
[New] - Files in a tiered volume gets promoted when bitd signs them
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: ZStream
Depends On: 1278326
Blocks: glusterfs-3.7.6
  Show dependency treegraph
 
Reported: 2015-11-05 23:27 EST by Joseph Elwin Fernandes
Modified: 2016-06-19 20:00 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1278326
Environment:
Last Closed: 2015-11-17 01:02:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-10 21:03:45 EST
REVIEW: http://review.gluster.org/12568 (tier/ctr: ignoring bitrot scrubber fops) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2015-11-10 22:04:48 EST
REVIEW: http://review.gluster.org/12568 (tier/ctr: ignoring bitrot scrubber fops) posted (#3) for review on release-3.7 by Joseph Fernandes
Comment 3 Vijay Bellur 2015-11-10 22:26:27 EST
REVIEW: http://review.gluster.org/12568 (tier/ctr: ignoring bitrot scrubber fops) posted (#4) for review on release-3.7 by Joseph Fernandes
Comment 4 Vijay Bellur 2015-11-11 09:19:49 EST
COMMIT: http://review.gluster.org/12568 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 000a4f1c12c2377e174f2a163ebd6c29698007d0
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Mon Nov 9 20:36:11 2015 +0530

    tier/ctr: ignoring bitrot scrubber fops
    
    We had missed adding  GF_CLIENT_PID_SCRUB to the internal fops
    list of bitrot. Doing that in this fix
    
    backport of http://review.gluster.org/#/c/12555/
    
    > Change-Id: I0c7de37e2bf625fb577a32a599a885ee95f5d3bd
    > BUG: 1278326
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/12555
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Venky Shankar <vshankar@redhat.com>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: I30384e970531d2f23d32a512ac2986ca6661af7c
    BUG: 1278640
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/12568
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 5 Raghavendra Talur 2015-11-17 01:02:38 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.6, please open a new bug report.

glusterfs-3.7.6 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-November/024359.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 6 Kaushal 2016-04-19 03:47:28 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.