Bug 1278730 - SimplePagedResults -- abandon could happen between the abandon check and sending results
SimplePagedResults -- abandon could happen between the abandon check and send...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
: ZStream
Depends On: 1278567
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 05:02 EST by Jan Kurik
Modified: 2016-05-02 02:06 EDT (History)
7 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.4.0-21.el7_2
Doc Type: Bug Fix
Doc Text:
Prior to this update, the Directory Server could receive an abandon request for a SimplePagedResults request in the source code between the abandon check and the part of source code that sends the search results. Consequently, the abandon request freed the search results that the result-sending code still referred to, and the Directory Server terminated unexpectedly. Now, the source code that sends the search result is protected by a lock, which prevents the abandon request from occurring. As a result, the Directory Server no longer crashes in the described situation.
Story Points: ---
Clone Of: 1278567
Environment:
Last Closed: 2015-12-08 05:33:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-06 05:02:37 EST
This bug has been copied from bug #1278567 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 6 Noriko Hosoi 2015-11-17 12:57:42 EST
See [Bug 1282607] New: 389-ds-base-1.2.11.15-67.el6_7 hang
Comment 8 Amita Sharma 2015-11-20 06:56:30 EST
Executed Simple paged search acceptance test with latest build ::
SIMPLEPAGED startup 	100% (1/1) 	  	 
SIMPLEPAGED run 	100% (17/17) 	  	 
SIMPLEPAGED cleanup 	100% (1/1)

[root@dhcp201-167 ~]# rpm -qa | grep 389
389-ds-base-1.3.4.0-21.el7_2.x86_64
389-ds-base-debuginfo-1.3.4.0-21.el7_2.x86_64
389-ds-base-libs-1.3.4.0-21.el7_2.x86_64


Note : this bug is verified as Sanity Only Check.
Comment 10 errata-xmlrpc 2015-12-08 05:33:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2572.html

Note You need to log in before you can comment on or make changes to this bug.