Bug 1278894 - cold-plugged DIMM can't be unplugged on the first unplug request
Summary: cold-plugged DIMM can't be unplugged on the first unplug request
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Igor Mammedov
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1305606 1283072 1288337
TreeView+ depends on / blocked
 
Reported: 2015-11-06 16:53 UTC by Igor Mammedov
Modified: 2016-11-07 21:36 UTC (History)
12 users (show)

Fixed In Version: qemu-kvm-rhev-2.5.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1283072 (view as bug list)
Environment:
Last Closed: 2016-11-07 21:36:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description Igor Mammedov 2015-11-06 16:53:50 UTC
Description of problem:
/usr/libexec/qemu-kvm -m 4G,slots=8,maxmem=32G rhel72.img  -object memory-backend-ram,id=m0,size=128M -device pc-dimm,id=dimm0,memdev=m0  -monitor stdio

then after guest booted do in monitor:
 
   device_del dimm0

to hotunplug coldplugged memory.
Guest will print on console:
--
ACPI: \_SB_.MP00: ACPI_NOTIFY_DEVICE_CHECK event
acpi PNP0C80:00: Already enumerated
--
and DIMM isn't unplugged.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.3.0-31

How reproducible:
100%

Actual results:
DIMM isn't unplugged

Expected results:
DIMM is unplugged or guest should at least
print following message:
 ACPI: \_SB_.MP00: ACPI_NOTIFY_EJECT_REQUEST event

Comment 2 Yumei Huang 2015-11-12 11:30:09 UTC
Reproduce:
kernel: 3.10.0-329.el7.x86_64
qemu: qemu-kvm-rhev-2.3.0-29.el7

QE retested this bug on the above environment,then got the same result.
So, the bug is reproduced on the above environment.


Verify:
kernel: 3.10.0-329.el7.x86_64
qemu: qemu-kvm-rhev-2.3.0-31.el7.next.candidate

QE retested this bug on the above environment. After do "device_del dimm0" in monitor, the DIMM is unplugged.
So, the bug is fixed.

Comment 4 Miroslav Rezanina 2015-11-18 10:07:33 UTC
Fix included in qemu-kvm-rhev-2.3.0-31.el7_2.2

Comment 7 Yumei Huang 2016-05-18 08:09:50 UTC
Reproduce:
qemu-kvm-rhev-2.3.0-31.el7
kernel-3.10.0-366.el7.x86_64

Steps:
1. boot guest with pc-dimm
# /usr/libexec/qemu-kvm  -m 4G,slots=8,maxmem=32G -smp 4   \

-drive file=/home/guest/RHEL-Server-7.3-64-virtio.qcow2,id=drive-virtio-disk1,media=disk,cache=none,snapshot=off,format=qcow2,aio=native,if=none  -device virtio-blk-pci,bus=pci.0,addr=0x4,drive=drive-virtio-disk1,bootindex=0                                      \

  -netdev tap,id=idw97X5F  -device virtio-net-pci,netdev=idw97X5F,mac='9a:37:37:37:37:8e',bus=pci.0,addr=0x5,id='idMqFTXq' -vga cirrus   -monitor stdio  -vnc :0   \

 -object memory-backend-ram,id=m0,size=128M -device pc-dimm,id=dimm0,memdev=m0               \

 -serial unix:/tmp/console,server,nowait

2. unplug pc-dimm
(qemu) device_del dimm0

The dimm0 is not unplugged.
So the bug is reproduced. 

Verify:
qemu-kvm-rhev-2.6.0-1.el7
kernel-3.10.0-366.el7.x86_64

With same steps as above, dimm0 is unplugged. 
So the bug is fixed.

Comment 10 errata-xmlrpc 2016-11-07 21:36:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.