Bug 1283072 - cold-plugged DIMM can't be unplugged on the first unplug request
cold-plugged DIMM can't be unplugged on the first unplug request
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev (Show other bugs)
7.2
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Igor Mammedov
Virtualization Bugs
: ZStream
Depends On: 1278894
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-18 02:40 EST by Jan Kurik
Modified: 2015-12-07 16:43 EST (History)
10 users (show)

See Also:
Fixed In Version: qemu-kvm-rhev-2.3.0-31.el7_2.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1278894
Environment:
Last Closed: 2015-12-07 16:43:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-11-18 02:40:09 EST
This bug has been copied from bug #1278894 and has been proposed
to be backported to 7.2 z-stream (EUS).
Comment 3 Yumei Huang 2015-11-19 03:57:59 EST
Reproduce:
kernel: 3.10.0-329.el7.x86_64
qemu: qemu-kvm-rhev-2.3.0-29.el7

steps:
1. start a guest:
/usr/libexec/qemu-kvm -m 4G,slots=8,maxmem=32G rhel72.img  -object memory-backend-ram,id=m0,size=128M -device pc-dimm,id=dimm0,memdev=m0  -monitor stdio
2. after guest booted do unplug in monitor:
   (qemu)device_del dimm0

Guest  print on console:
--
ACPI: \_SB_.MP00: ACPI_NOTIFY_DEVICE_CHECK event
acpi PNP0C80:00: Already enumerated
--
and DIMM isn't unplugged.

So the bug is reproduced on above environment. 


Reverify:
kernel: 3.10.0-331.el7.x86_64
qemu-kvm: qemu-kvm-rhev-2.3.0-31.el7_2.2

With same steps as above, the DIMM is unplugged. 
So the bug is fixed.
Comment 4 Yumei Huang 2015-11-23 02:01:59 EST
Reverify:
kernel: 3.10.0-327.3.1.el7.x86_64
qemu-kvm: qemu-kvm-rhev-2.3.0-31.el7_2.3

QE test on above environment with same steps as comment 3, the DIMM is unplugged. 
So the bug is fixed.
Comment 9 errata-xmlrpc 2015-12-07 16:43:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2555.html

Note You need to log in before you can comment on or make changes to this bug.