This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1278907 - Add project quotas without tenant quotas
Add project quotas without tenant quotas
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Libor Pichler
Pavol Kotvan
:
Depends On:
Blocks: 1289707
  Show dependency treegraph
 
Reported: 2015-11-06 12:35 EST by Sergio Ocon
Modified: 2016-06-29 11:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289707 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:02:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Ocon 2015-11-06 12:35:59 EST
Description of problem:
When you create a new project in a tenant and you try to assign a quota, it comñplaints with message "Error when saving tenant quota: Validation failed: Cpu allocated quota is over allocated, parent tenant does not have enough quota"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a tenant
2. Create a project
3. Try to add a quota to the project

Actual results:
Error when saving tenant quota: Validation failed: Cpu allocated quota is over allocated, parent tenant does not have enough quota

Expected results:
If the parent does not have a quota assigned (inifinte), it should work. Default quotas should not be 0 but nil

Additional info:
Comment 3 CFME Bot 2015-11-24 09:00:28 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/373fb173b8979e020a10f585a2d923ce0323a3eb

commit 373fb173b8979e020a10f585a2d923ce0323a3eb
Author:     Libor Pichler <lpichler@redhat.com>
AuthorDate: Fri Nov 20 16:00:04 2015 +0100
Commit:     Libor Pichler <lpichler@redhat.com>
CommitDate: Mon Nov 23 09:52:29 2015 +0100

    Add spec for allowing to enter infinity tenant quota
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1278907

 spec/models/tenant_quota_spec.rb | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
Comment 4 CFME Bot 2015-11-24 09:00:34 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/eb3564ae4748284b7a6aef20e008489342ba63fe

commit eb3564ae4748284b7a6aef20e008489342ba63fe
Author:     Libor Pichler <lpichler@redhat.com>
AuthorDate: Fri Nov 20 16:02:08 2015 +0100
Commit:     Libor Pichler <lpichler@redhat.com>
CommitDate: Mon Nov 23 09:52:29 2015 +0100

    Allow enter infinity tenant quota
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1278907
    It is allowed when parent tenant doesn't have defined related tenant quota

 app/models/tenant_quota.rb | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
Comment 5 CFME Bot 2015-12-14 17:50:24 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=726df7a940266397c8c8905f52dbc4e99e4a5255

commit 726df7a940266397c8c8905f52dbc4e99e4a5255
Author:     Libor Pichler <lpichler@redhat.com>
AuthorDate: Fri Nov 20 16:00:04 2015 +0100
Commit:     Libor Pichler <lpichler@redhat.com>
CommitDate: Wed Nov 25 17:09:50 2015 +0100

    Add spec for allowing to enter infinity tenant quota
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1278907
    (cherry picked from commit 373fb173b8979e020a10f585a2d923ce0323a3eb)

 spec/models/tenant_quota_spec.rb | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
Comment 6 CFME Bot 2015-12-14 17:50:28 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2947a335e2aefd6c436231f4343d89e39e6f7d8c

commit 2947a335e2aefd6c436231f4343d89e39e6f7d8c
Author:     Libor Pichler <lpichler@redhat.com>
AuthorDate: Fri Nov 20 16:02:08 2015 +0100
Commit:     Libor Pichler <lpichler@redhat.com>
CommitDate: Wed Nov 25 17:10:46 2015 +0100

    Allow enter infinity tenant quota
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1278907
    It is allowed when parent tenant doesn't have defined related tenant quota
    
    (cherry picked from commit eb3564ae4748284b7a6aef20e008489342ba63fe)

 app/models/tenant_quota.rb | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
Comment 9 errata-xmlrpc 2016-06-29 11:02:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.