Bug 1279074 - Keyboard layout switching not working after reboot
Keyboard layout switching not working after reboot
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: mate-panel (Show other bugs)
23
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Wolfgang Ulbrich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-07 12:30 EST by Assen Totin
Modified: 2015-11-12 14:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 14:34:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Assen Totin 2015-11-07 12:30:43 EST
Description of problem:
After each boot keyboard layout switching does not work (neither by pressing the designated key nor by clicking the mouse in the panel). The only way to make it work is to change the layout switching key in the keyboard properties.

Version-Release number of selected component (if applicable):
Fedora MATE 23 spin-off on i686 (installed from MATE Live CD), clean install, all updates at the time of writing.

How reproducible:
On every reboot.

Steps to Reproduce:
1. Install Fedora 23 MATE spin-off from the Live CD.
2. After first boot, add a second layout in keyboard preferences. Choose a keyboard switching key (e.g., Left Win key in my case). Verify keyboard layout can be switched by using the switch key or by clicking the layout indicator in the system tray area.
3. Reboot.

Actual results:
Neither the keyboard switch nor a mouse click on the layout indicator in the system tray can switch the language; even a right-click on the layout indicator and then selection of a layout from the list cannot switch the layout. 

Expected results:
Language switch should work from keyboard or by mouse click - like it always did before.

Additional info:
After reboot, the default keyboard layout is displayed in the tray. Right-clicking it shows both layouts are present. The same hardware (same PC, keyboard and mouse) had F21 + MATE, then F22 + MATE installed the same way and keyboard layout change had always worked.

To make the layout switch work again, open keyboard preferences and select another layout switch key (no need to disable the existing one, just add a second one); you can then immediately remove the new key (no need to even close the window) and the original key starts working right away; also, changing the layout by a mouse click begins to work.

Oddly enough, just removing the original switch key form the preferences and then adding it back does not work; you need to replace it with another one or to add a second one to make layout switching work.
Comment 1 Wolfgang Ulbrich 2015-11-07 14:40:19 EST
Hi Assen,
i've only a fresh f24 installation (from today, installed f23 64bit livecd--> using yum to updrade to f24) on my notebook, here i can switch the layout via indicator in notification area with the mouse after a reboot. I use german and english layout.
Need to check this on my normal box, but here i've only a old f23 installation from summer.
Honestly, deleting the default usa layout is the first thing what i do after installation, so i never checked this.
Comment 2 Wolfgang Ulbrich 2015-11-07 14:42:07 EST
Btw., why are you using i686?
i can't imagine that you hardware does not support x86_64.
Comment 3 Assen Totin 2015-11-09 18:05:28 EST
Hi, Wolfgang,

I keep the USA layout because my keyboard matches it. My locale set to en_GB, but the keyboard uses US layout - with UK layout many hings like % sign, $ sign, caret, braces move to other keys and it gets inconvenient (I already have to remember some keys on my Mac keyboard at the office which do not match the US layout...)

I've never seen this problem before - neither in Gnome 2 not in MATE. It's truly first time. I read something about F23 coming with a new X.org version - might it be because of it? The fact that I cannot change the layout even with the mouse is what puzzles me most. 

Re: i686: I see no reason to run x86_64 on a desktop. On my office Mac I am forced to run x86_64 Fedora (it is UEFI), but because of stuff like Skype, Cisco WebEx, vSphere in Wine etc. I actually have most packages installed (and loaded into memory) also in i686 version. I even have to run a 32-bit browser with 32-bit JRE... there is many more proprietary Desktop software which is 32-bit only - IBM is a good example with ClearCase. Finally, I see no reason to spend more RAM for the same thing - my home desktop is a nice old quiet machine with 2 GB RAM and I see no reason to replace it just because they don't make DDR2 any more. So, I'll run i686 as long as they make it :)

WWell,

Assen
Comment 4 Wolfgang Ulbrich 2015-11-10 05:58:08 EST
I did a fresh f23 installation on my normal box and i can't reproduce it there too.
Layout switching works fine with my layouts.
Between f21/f22/f23 are no differents, libmatekbd and mate-control-center use the same tarball from upstream.
Was it working with an older fedora version on this box?
Does it happen with another layouts too?
Comment 5 Assen Totin 2015-11-10 16:50:33 EST
Yes, same box has F22 and before that had F21, and F20... every time it worked. It may be somehow related to X.org, of which F23 runs an RC. At, least I'm sure it's not Compiz, because the same thing happens when I use Marco. 

I have an issue with X.org crashing when the machine is idle https://bugzilla.redhat.com/show_bug.cgi?id=1279077 - so they both may be related somehow. 

The only difference between my F23 and previous is nouveau driver. I have always used nvidia so far (which is definitely better), but in F22 Firefox (with GTK3) keeps randomly crashing a few times every day (and in F23 with nouveau I had no had a single crash in a week); also, Dropbox is so dumb that it ships its own GL library which conflicts with the one from nvidia driver and their icon as a result is broken. 

I'll wait for the official package of X.Org 1.18 to arrive, but I don't believe there is anything in my setup which justifies a re-install. The fact that everything starts working once I add/remove a second layout switch key, or add/remove a layout, means my setup is fine and something else is broken.
Comment 6 Assen Totin 2015-11-12 14:34:10 EST
After removing en_US layout (keeping bg_BG as only layout) and then re-adding en_US, the problem is gone. 

The issue may be related to the fact that I added bg_BG as second layout and designated the keyboard switching layout in Anaconda, during the setup. I usually try to fiddle as less as possible during setup, but this time decided to take advantage of Anaconda. 

So, it may be worth exploring whether the issue will not occur if a second layout and a layout switching key is added in Anaconda during setup.

Note You need to log in before you can comment on or make changes to this bug.