Bug 1279151 - System wide plasma-desktop-appletsrc settings not reflected in user profile
System wide plasma-desktop-appletsrc settings not reflected in user profile
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kdebase (Show other bugs)
6.7
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
: ZStream
: 1294213 (view as bug list)
Depends On:
Blocks: 1271696 1305833
  Show dependency treegraph
 
Reported: 2015-11-08 02:30 EST by jigar
Modified: 2016-05-10 15:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1305833 (view as bug list)
Environment:
Last Closed: 2016-05-10 15:36:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
plasma-desktop-appletsrc (2.56 KB, text/plain)
2015-11-08 02:34 EST, jigar
no flags Details
plasma-desktop-appletsrc revised version (3.82 KB, text/plain)
2015-11-18 08:12 EST, jigar
no flags Details

  None (edit)
Description jigar 2015-11-08 02:30:44 EST
Description of problem: When new stuff is added to /usr/share/kde-settings/kde-profile/default/share/config/plasma-desktop-appletsrc, the icons seem to be set up as per the file EXCEPT that the icons should be 80 by 80 pixels and the plasma-desktop-appletsrc file has them resized to 50 by 50.

How reproducible: Always


Steps to Reproduce:

1) Set up /usr/share/kde-settings/kde-profile/default/share/config/plasma-desktop-appletsrc as attached

2) Destroy, if they exist, user's .kde and .local directories, also the /var/tmp/kdecache-<username> file

3) Have user log in

What should happen is that a new .kde directory is created, and the icons from the system plasma-desktop-appletsrc appear, but they don't.

4) Right-click on the desktop, change "Desktop Activity" from "Desktop" to "Folder View", then back again.

5) The icons all appear in their correct positions, except that they're all 50 by 50 and not 80 by 80 as they should be.


Actual results: The size of icons is resized 50x50.


Expected results: The size of icons should be 80x80 and it should follow the the settings as per the global file.


Additional info: Upstream Bug : https://bugs.kde.org/show_bug.cgi?id=323211 seems related.
Comment 1 jigar 2015-11-08 02:34 EST
Created attachment 1091224 [details]
plasma-desktop-appletsrc
Comment 3 Jan Grulich 2015-11-09 04:06:22 EST
What icons do you mean? I don't see anything set to 80x80 in your plasma-desktop-appletsrc.
Comment 5 jigar 2015-11-18 08:12 EST
Created attachment 1096060 [details]
plasma-desktop-appletsrc revised version

Please check with this version of plasma-desktop-appletsrc file. Remove the word "(revised)" to use it directly.
Comment 9 Jan Grulich 2015-12-02 07:24:35 EST
As discussed with customer on RH customer portal, we will workaround this temporarily by adding Konsole to the context menu for folder view, thus granting dev_ack.
Comment 12 Jan Grulich 2015-12-08 04:18:30 EST
Fixed in kdebase-4.3.4-9.el6.
Comment 14 Jan Grulich 2016-01-27 15:36:10 EST
*** Bug 1294213 has been marked as a duplicate of this bug. ***
Comment 20 errata-xmlrpc 2016-05-10 15:36:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0744.html

Note You need to log in before you can comment on or make changes to this bug.