Bug 1279254 - SELinux is preventing abrt-hook-ccpp from 'open' accesses on the file /dev/shm/pulse-shm-4149815034.
SELinux is preventing abrt-hook-ccpp from 'open' accesses on the file /dev/sh...
Status: CLOSED DUPLICATE of bug 1276931
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e37eff38c3475efa407b1121d38...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 16:39 EST by Justin W. Flory
Modified: 2015-11-09 05:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 05:54:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin W. Flory 2015-11-08 16:39:43 EST
Description of problem:
SELinux is preventing abrt-hook-ccpp from 'open' accesses on the file /dev/shm/pulse-shm-4149815034.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that abrt-hook-ccpp should be allowed open access on the pulse-shm-4149815034 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-hook-ccpp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_dump_oops_t:s0
Target Context                unconfined_u:object_r:user_tmp_t:s0
Target Objects                /dev/shm/pulse-shm-4149815034 [ file ]
Source                        abrt-hook-ccpp
Source Path                   abrt-hook-ccpp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.18.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.3-200.fc22.x86_64 #1 SMP Thu
                              Oct 8 03:23:55 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-11-08 16:38:33 EST
Last Seen                     2015-11-08 16:38:33 EST
Local ID                      26f588f8-b418-4547-aa51-4d0b9397dbbb

Raw Audit Messages
type=AVC msg=audit(1447018713.779:975): avc:  denied  { open } for  pid=12349 comm="abrt-hook-ccpp" path="/dev/shm/pulse-shm-4149815034" dev="tmpfs" ino=372497 scontext=system_u:system_r:abrt_dump_oops_t:s0 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file permissive=0


Hash: abrt-hook-ccpp,abrt_dump_oops_t,user_tmp_t,file,open

Version-Release number of selected component:
selinux-policy-3.13.1-128.18.fc22.noarch

Additional info:
reporter:       libreport-2.6.3
hashmarkername: setroubleshoot
kernel:         4.2.3-200.fc22.x86_64
type:           libreport

Potential duplicate: bug 1279084
Comment 1 Miroslav Grepl 2015-11-09 05:54:18 EST

*** This bug has been marked as a duplicate of bug 1276931 ***

Note You need to log in before you can comment on or make changes to this bug.