Bug 1279319 - [GlusterD]: Volume start fails post add-brick on a volume which is not started
[GlusterD]: Volume start fails post add-brick on a volume which is not started
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
3.1
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Mohammed Rafi KC
Byreddy
glusterd
: ZStream
Depends On:
Blocks: 1279351 1282322
  Show dependency treegraph
 
Reported: 2015-11-09 02:31 EST by Byreddy
Modified: 2017-03-25 10:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1279351 (view as bug list)
Environment:
Last Closed: 2017-03-25 10:24:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Byreddy 2015-11-09 02:31:40 EST
Description of problem:
=======================
Volume start is failing with " Commit failed" when brick is added to stopped state volume.


Version-Release number of selected component (if applicable):
=============================================================
glusterfs-3.7.5-5

How reproducible:
=================
100%


Steps to Reproduce:
===================
1.Have one node cluster
2.Create a volume of type Distributed (1*1) // ** DON'T START THE VOLUME **
3.Add a new brick 
4.Start the volume now // it will fail 

Actual results:
===============
Volume start is failing with "Commit failed"


Expected results:
================
Volume start should work without any issue.


Additional info:
Comment 2 Atin Mukherjee 2015-11-09 02:44:40 EST
Here goes the RCA for the same:

the add-brick code path has caused a regression when brick(s) are added into a volume which is not started. The issue here is although the add-brick throws up a success message it doesn't generate the volfiles because of which at the time of start brick process in volume start the __server_getspec at glusterd fails since the brick volfile doesn't exist.
Comment 4 Byreddy 2015-11-09 04:07:41 EST
Additional info to reproduce the issue:
=======================================
Update node from 3.1.1 build to 3.1.2 

Then follow the remaining steps specified in description section.
Comment 5 Mohammed Rafi KC 2015-11-09 04:10:53 EST
Add-brick implementation has been changed to v3 framework from glusterfs-3.7.6 in upstream. if cluster is running a version equal to or less than GLUSTERFS_3_7_5 , we will fall back into the older implementation. This bug is in the fall back code, where it complete the commit phase without creating the volfiles for newly added brick.
Comment 7 Atin Mukherjee 2016-08-16 11:01:06 EDT
The fix is already part of rhgs-3.1.2 as per comment 6, moving it to ON_QA
Comment 8 Byreddy 2016-11-27 23:02:17 EST
Verified this bug using the build - glusterfs-3.8.4-5.el7rhgs.x86_64

Fix is working good, reported issue no more exist.

Moving to verified state.

Note You need to log in before you can comment on or make changes to this bug.