This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1282322 - [GlusterD]: Volume start fails post add-brick on a volume which is not started
[GlusterD]: Volume start fails post add-brick on a volume which is not started
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Mohammed Rafi KC
: Triaged, ZStream
Depends On: 1279319 1279351
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-16 00:48 EST by Mohammed Rafi KC
Modified: 2016-06-16 09:44 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1279351
Environment:
Last Closed: 2016-06-16 09:44:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-16 00:49:06 EST
REVIEW: http://review.gluster.org/12552 (glusterd: brick failed to start) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-11-16 04:20:01 EST
COMMIT: http://review.gluster.org/12552 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 571cbcf56ef865d64ebdb1621c791fe467501e52
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon Nov 9 16:43:21 2015 +0530

    glusterd: brick failed to start
    
    brick volfiles are generated in post validate, if
    it is running version higher than GLUSTER_3_7_5,
    else will be running in syncop.
    
    If the code fall back to syncop, and volume is stopped
    then we were returning the operation with out generating
    volfiles.
    
    Change-Id: I3b16ee29de19c5d34e45d77d6b7e4b665c2a4653
    BUG: 1282322
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12552
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 3 Mike McCune 2016-03-28 18:22:31 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Niels de Vos 2016-06-16 09:44:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.