Bug 1279327 - [Snapshot]: Clone creation fails on tiered volume with pre-validation failed message
[Snapshot]: Clone creation fails on tiered volume with pre-validation failed ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Avra Sengupta
: ZStream
Depends On: 1278254
Blocks: 1287538
  Show dependency treegraph
 
Reported: 2015-11-09 03:06 EST by Avra Sengupta
Modified: 2016-06-16 09:43 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1278254
: 1287538 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:43:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Avra Sengupta 2015-11-09 03:45:40 EST
Fix at http://review.gluster.org/#/c/12548/2
Comment 2 Vijay Bellur 2015-12-02 02:45:48 EST
REVIEW: http://review.gluster.org/12548 (snapshot/clone : Fix tier pause failure for snapshot clone) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 3 Vijay Bellur 2015-12-03 00:57:50 EST
COMMIT: http://review.gluster.org/12548 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 0d46f1b0519f93165a335bf264661054883b522f
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Mon Nov 9 13:37:53 2015 +0530

    snapshot/clone : Fix tier pause failure for snapshot clone
    
    On a tiered volume, snapshot clone fails while trying to
    pause tier, as we pass volname(snap) to the brick_op_phase module,
    which tries to look for the snap volume amongst regular
    volumes, and obviously doesn't find it and fail.
    
    Well as snapshot volumes are read only volume, and will not
    have tiering daemon acting upon them, there is really no need
    to pause tiereing while taking clone of snapshot volumes. Hence
    removing the code to pause and resume tiering during clone create.
    
    Change-Id: I2266aba589a830a13a806c0d8a56fd8855143ccd
    BUG: 1279327
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/12548
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:43:35 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.