Bug 1287538 - [Snapshot]: Clone creation fails on tiered volume with pre-validation failed message
[Snapshot]: Clone creation fails on tiered volume with pre-validation failed ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
3.7.6
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Avra Sengupta
: ZStream
Depends On: 1278254 1279327
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-02 05:10 EST by Avra Sengupta
Modified: 2016-04-19 03:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1279327
Environment:
Last Closed: 2016-02-15 03:55:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-02 05:17:05 EST
REVIEW: http://review.gluster.org/12846 (snapshot/clone : Fix tier pause failure for snapshot clone) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)
Comment 2 Vijay Bellur 2015-12-03 00:58:59 EST
COMMIT: http://review.gluster.org/12846 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit d84242276b2f8ee7151c7784992dffb651816ccf
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Mon Nov 9 13:37:53 2015 +0530

    snapshot/clone : Fix tier pause failure for snapshot clone
    
        Backport of http://review.gluster.org/#/c/12548
    
    On a tiered volume, snapshot clone fails while trying to
    pause tier, as we pass volname(snap) to the brick_op_phase module,
    which tries to look for the snap volume amongst regular
    volumes, and obviously doesn't find it and fail.
    
    Well as snapshot volumes are read only volume, and will not
    have tiering daemon acting upon them, there is really no need
    to pause tiereing while taking clone of snapshot volumes. Hence
    removing the code to pause and resume tiering during clone create.
    
    Change-Id: I2266aba589a830a13a806c0d8a56fd8855143ccd
    BUG: 1287538
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/12846
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 3 Kaushal 2016-04-19 03:49:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.