Bug 1279376 - Data Tiering:Rename of cold file to a hot file causing split brain and showing two copies of files in mount point
Data Tiering:Rename of cold file to a hot file causing split brain and showi...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Nithya Balachandran
bugs@gluster.org
:
Depends On: 1277088
Blocks: 1283480
  Show dependency treegraph
 
Reported: 2015-11-09 05:18 EST by Nithya Balachandran
Modified: 2016-06-16 09:43 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1277088
: 1283480 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:43:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Nithya Balachandran 2015-11-09 05:43:56 EST
Patch posted at:
http://review.gluster.org/#/c/12551/
Comment 2 Vijay Bellur 2015-11-16 01:34:59 EST
REVIEW: http://review.gluster.org/12551 (cluster/tier: Do not delete linkto file on demotion) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 3 Vijay Bellur 2015-11-17 10:06:37 EST
REVIEW: http://review.gluster.org/12551 (cluster/tier: Do not delete linkto file on demotion) posted (#3) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 4 Vijay Bellur 2015-11-17 12:58:14 EST
REVIEW: http://review.gluster.org/12551 (cluster/tier: Do not delete linkto file on demotion) posted (#4) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 5 Vijay Bellur 2015-11-18 00:11:06 EST
REVIEW: http://review.gluster.org/12551 (cluster/tier: Do not delete linkto file on demotion) posted (#5) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 6 Vijay Bellur 2015-11-18 09:55:58 EST
REVIEW: http://review.gluster.org/12551 (cluster/tier: Do not delete linkto file on demotion) posted (#6) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 7 Vijay Bellur 2015-11-18 10:16:16 EST
COMMIT: http://review.gluster.org/12551 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit a1e4be4d277c8150657f7b9fd4b72dcdd639523d
Author: N Balachandran <nbalacha@redhat.com>
Date:   Mon Nov 9 15:49:50 2015 +0530

    cluster/tier: Do not delete linkto file on demotion
    
    The current DHT migration code will always delete the
    src linkto file after migration as dht always moves
     files to the hashed subvol. This is not the case in tiering.
    The lack of linkto files causes rename to fail leaving 2 files
     with the same name but different gfids on the volume.
    Modified to leave the linkto file behind if the source
     volume is the hashed subvolume.
    
    Change-Id: I2b99f7d34b4b719aee6232dc40c6a8f8ba88225d
    BUG: 1279376
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12551
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 8 Niels de Vos 2016-06-16 09:43:35 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.