This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1283480 - Data Tiering:Rename of cold file to a hot file causing split brain and showing two copies of files in mount point
Data Tiering:Rename of cold file to a hot file causing split brain and showi...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Nithya Balachandran
bugs@gluster.org
:
Depends On: 1277088 1279376
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-19 00:50 EST by Nithya Balachandran
Modified: 2016-04-19 03:48 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1279376
Environment:
Last Closed: 2016-04-19 03:48:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-19 00:53:49 EST
REVIEW: http://review.gluster.org/12655 (cluster/tier: Do not delete linkto file on demotion) posted (#1) for review on release-3.7 by N Balachandran (nbalacha@redhat.com)
Comment 2 Vijay Bellur 2015-11-19 13:05:46 EST
COMMIT: http://review.gluster.org/12655 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 79103a0f9eea2af4c68710e602f78963471ecec7
Author: N Balachandran <nbalacha@redhat.com>
Date:   Mon Nov 9 15:49:50 2015 +0530

    cluster/tier: Do not delete linkto file on demotion
    
    The current DHT migration code will always delete the
    src linkto file after migration as dht always moves
     files to the hashed subvol. This is not the case in tiering.
    The lack of linkto files causes rename to fail leaving 2 files
     with the same name but different gfids on the volume.
    Modified to leave the linkto file behind if the source
     volume is the hashed subvolume.
    
    > Change-Id: I2b99f7d34b4b719aee6232dc40c6a8f8ba88225d
    > Signed-off-by: N Balachandran <nbalacha@redhat.com>
    > Reviewed-on: http://review.gluster.org/12551
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: I210b94cdae0409c87af8ba198e3cd263a6c85190
    BUG: 1283480
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/12655
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:48:31 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.