Bug 1279380 - undefined method `find' for ManageIQ:Module
undefined method `find' for ManageIQ:Module
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.6.0
Assigned To: Ladislav Smola
Dave Johnson
openstack
:
Depends On:
Blocks: 1290397
  Show dependency treegraph
 
Reported: 2015-11-09 05:53 EST by Marius Cornea
Modified: 2016-06-29 11:03 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290397 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:03:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2015-11-09 05:53:06 EST
Description of problem:
After adding an Openstack Platform Director provider and running SmartState analysis on the associated nodes I can see i the evm.log such error messages:
 ERROR -- : MIQ(MiqQueue#m_callback) Message id: [465]: undefined method `find' for ManageIQ:Module

Version-Release number of selected component (if applicable):
5.5.0.9-beta2.20151102161742_5530c9a

How reproducible:
100%

Steps to Reproduce:
1. Add Openstack Platform Director provider
2. Run SmartState analysis on all the nodes
3. grep 'undefined method' /var/www/miq/vmdb/log/evm.log

Actual results:
There are a bunch of occurences of 'undefined method `find' for ManageIQ:Module' errors.

Expected results:
No errors would show up.

Additional info:
I couldn't find out what is causing this. Please let me know any steps on how I could investigate it further.

Attaching the evm.log.
Comment 3 CFME Bot 2015-11-10 08:40:31 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/7d0ed09773801afa98c87eb2b6cc21f96122b36f

commit 7d0ed09773801afa98c87eb2b6cc21f96122b36f
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Mon Nov 9 15:06:33 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Tue Nov 10 09:01:36 2015 +0100

    Fixing bad parsing of class and PID
    
    Before the classes were in format e.g EmsCluster:8, so split(":")
    would work. Now all classes are namespaced, so we can't do that.
    
    Fixing by parsing with lookbehind and lookahead, that checks we
    parse by single colon.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1279380

 app/models/metric/ci_mixin/capture.rb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
Comment 5 CFME Bot 2016-01-11 21:27:41 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=49fdc254d490dce21b10689284b836d08d321f96

commit 49fdc254d490dce21b10689284b836d08d321f96
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Mon Nov 9 15:06:33 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Mon Jan 11 17:23:28 2016 +0100

    Fixing bad parsing of class and PID
    
    Before the classes were in format e.g EmsCluster:8, so split(":")
    would work. Now all classes are namespaced, so we can't do that.
    
    Fixing by parsing with lookbehind and lookahead, that checks we
    parse by single colon.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1279380

 app/models/metric/ci_mixin/capture.rb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
Comment 6 CFME Bot 2016-01-11 21:27:52 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=6d28929158f1e19edac97007ffcf299d81de3004

commit 6d28929158f1e19edac97007ffcf299d81de3004
Merge: 772033a 49fdc25
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Mon Jan 11 21:23:36 2016 -0500
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Mon Jan 11 21:23:36 2016 -0500

    Merge branch 'bz1290397' into '5.5.z'
    
    Fixing bad parsing of class and PID
    
    Before the classes were in format e.g EmsCluster:8, so split(":")
    would work. Now all classes are namespaced, so we can't do that.
    
    Fixing by parsing with lookbehind and lookahead, that checks we
    parse by single colon.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1279380
    
    Clean cherry-pick of
    https://github.com/ManageIQ/manageiq/pull/5354
    
    5.5.z BZ
    https://bugzilla.redhat.com/show_bug.cgi?id=1290397
    
    See merge request !695

 app/models/metric/ci_mixin/capture.rb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
Comment 7 Ronnie Rasouli 2016-04-05 07:49:48 EDT
5.5.3.2 tested the SSA on all nodes, no new undefined method found in evm.log
# date
Tue Apr  5 07:45:14 EDT 2016

[root@cfme ~]# grep 'undefined method' /var/www/miq/vmdb/log/evm.log
[----] E, [2016-04-05T07:35:22.012835 #11717:8dd998] ERROR -- : MIQ(MiqQueue#deliver) Message id: [231000000074685], Error: [undefined method `base_class' for NilClass:Class]
[----] E, [2016-04-05T07:35:22.047462 #11717:8dd998] ERROR -- : [NoMethodError]: undefined method `base_class' for NilClass:Class  Method:[rescue in deliver]
Comment 9 errata-xmlrpc 2016-06-29 11:03:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.