Bug 1290397 - undefined method `find' for ManageIQ:Module
undefined method `find' for ManageIQ:Module
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.5.2
Assigned To: Ladislav Smola
Ramesh A
openstack
: ZStream
Depends On: 1279380
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 07:26 EST by John Prause
Modified: 2016-02-10 10:23 EST (History)
9 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1279380
Environment:
Last Closed: 2016-02-10 10:23:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2016-01-11 21:27:56 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=6d28929158f1e19edac97007ffcf299d81de3004

commit 6d28929158f1e19edac97007ffcf299d81de3004
Merge: 772033a 49fdc25
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Mon Jan 11 21:23:36 2016 -0500
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Mon Jan 11 21:23:36 2016 -0500

    Merge branch 'bz1290397' into '5.5.z'
    
    Fixing bad parsing of class and PID
    
    Before the classes were in format e.g EmsCluster:8, so split(":")
    would work. Now all classes are namespaced, so we can't do that.
    
    Fixing by parsing with lookbehind and lookahead, that checks we
    parse by single colon.
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1279380
    
    Clean cherry-pick of
    https://github.com/ManageIQ/manageiq/pull/5354
    
    5.5.z BZ
    https://bugzilla.redhat.com/show_bug.cgi?id=1290397
    
    See merge request !695

 app/models/metric/ci_mixin/capture.rb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
Comment 4 Ramesh A 2016-01-28 08:32:09 EST
Good to go. Verified and working fine in 5.5.2.2.20160121120249_395c086
Comment 5 errata-xmlrpc 2016-02-10 10:23:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.