Bug 1279385 - Host received os-version by listenning port output mismatched with the guest's os version.
Host received os-version by listenning port output mismatched with the guest'...
Status: CLOSED DUPLICATE of bug 1279980
Product: ovirt-guest-agent
Classification: oVirt
Component: Core (Show other bugs)
---
Unspecified Unspecified
unspecified Severity low (vote)
: ---
: ---
Assigned To: Vinzenz Feenstra [evilissimo]
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 06:02 EST by Peixiu Hou
Modified: 2015-11-25 04:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-25 04:06:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: devel_ack?


Attachments (Terms of Use)

  None (edit)
Description Peixiu Hou 2015-11-09 06:02:55 EST
Description of problem:
Start a guest with the win10 32bit os, virtio-serial-pci, virtio-serial-port , rhev-guest-tools-iso. Install the vioser driver and the rhev-agent.msi, make sure the rhev-agent service is running. On the host ,open the listenning port, check the output data, “os-version” mismatched with the guest os. The listenning port output “os-version” is win8, but the guest os is win10. 
Listenning port output:
{"__name__": "os-version", "version": "Win 8"}

1. Verified with the windows 2012 r2, the lisenning port output “os-version” is win2012, not win2012r2.
{"__name__": "os-version", "version": "Win 2012"}
2. Verified with the win8.1, the lisenning port output “os-version” is win8, not win8.1.
{"__name__": "os-version", "version": "Win 8"}

And I'm so curious that the listenning port output data grab from where? Expected for your reply, thanks~~

Version-Release number of selected component (if applicable):
1.virtio-win-1.8.0-4.el7.noarch
2.qemu-kvm-rhev-0.12.1.2-2.479.el6_7.2.x86_64
3.kernel-2.6.32-573.9.1.el6.x86_64
4.seabios-0.6.1.2-30.el6.x86_64
5.Rhev-guest-tools-iso-3.5-11

How reproducible:
3/3

Steps to Reproduce:
1. Start guest with virtio-serial-pci,virtio-serial-port.rhev-guest-tools-iso.
/usr/libexec/qemu-kvm -M rhel6.5.0 -cpu SandyBridge -name win10 -enable-kvm -m 3G -smp 4 -uuid 2fd41914-5019-4d17-a6cc-fa653ba516f5 -nodefconfig -nodefaults -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=win10_x32.raw,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -spice id=on,disable-ticketing,port=5912 -vga qxl -qmp tcp:0:4444,server,nowait -monitor stdio -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:52:3b:35:88:00 -device virtio-serial-pci,id=virtio-serial0,max_ports=16 -chardev socket,id=channel1,host=127.0.0.1,port=12345,server,nowait -device virtserialport,chardev=channel1,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port1 -cdrom /usr/share/rhev-guest-tools-iso/rhev-tools-setup.iso
2. On the guest, install the vioser driver
3. Install the RHEV-agent.msi.
4. Open services.msc, start the RHEV-agents service, make sure the status is running.
5. On the host, open lisenning port:
    #nc localhost 12345
6. Check the listennning port output, the “os-version” shown “win8”. 
   ---------------issue occur.

Actual results:
{"__name__": "os-version", "version": "Win 8"}

Expected results:
Step 6: host can receive some data ,eg {"__name__": "os-version", "version": "Win10"}

Additional info:
I'm not sure the component is correct,correct me if I was wrong. Thanks~~
Comment 2 Vinzenz Feenstra [evilissimo] 2015-11-25 04:06:22 EST

*** This bug has been marked as a duplicate of bug 1279980 ***

Note You need to log in before you can comment on or make changes to this bug.