Bug 1279980 - [ovirt-guest-agent] Windows 10 and Windows 8.1 are reported as Win 8, Windows Server 2012 R2 as Windows Server 2012
[ovirt-guest-agent] Windows 10 and Windows 8.1 are reported as Win 8, Windows...
Status: CLOSED NEXTRELEASE
Product: ovirt-guest-agent
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
high Severity medium (vote)
: ovirt-3.5.7
: 1.0.11-4
Assigned To: Vinzenz Feenstra [evilissimo]
Jiri Belka
integration
:
: 1279385 (view as bug list)
Depends On:
Blocks: 1232584 1273808 1292387
  Show dependency treegraph
 
Reported: 2015-11-10 11:03 EST by Jiri Belka
Modified: 2015-12-17 05:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1292387 (view as bug list)
Environment:
Last Closed: 2015-12-17 05:10:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: ovirt‑3.5.z?
rule-engine: planning_ack?
michal.skrivanek: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48821 master MERGED win32: Update version information reporting for Win8+ and simplify Never
oVirt gerrit 49133 ovirt-3.6 MERGED win32: Update version information reporting for Win8+ and simplify Never
oVirt gerrit 49136 ovirt-3.5 MERGED win32: Update version information reporting for Win8+ and simplify Never

  None (edit)
Description Jiri Belka 2015-11-10 11:03:09 EST
Description of problem:

~~~
ed875d98-e407-4b07-967a-363cbecf3bb3
        Status = Up
        acpiEnable = true
        emulatedMachine = rhel6.5.0
        pid = 11785
        memGuaranteedSize = 930
        transparentHugePages = true
        displaySecurePort = 5900
        spiceSslCipherSuite = DEFAULT
        cpuType = Westmere
        smp = 2
        hypervEnable = true
        custom = {}
        vmType = kvm
        memSize = 2048
        smpCoresPerSocket = 1
        vmName = jb-w10-x64
...
~~~

~~~
ed875d98-e407-4b07-967a-363cbecf3bb3
        Status = Up
        displayInfo = [{'tlsPort': '5900', 'ipAddress': '10.34.62.40', 'port': '-1', 'type': 'spice'}]
        memUsage = 35
        acpiEnable = true
        pid = 11785
...
        appsList = ['QEMU guest agent', 'RHEV-Spice-Agent64 3.5.2', 'RHEV-Serial64 3.5.3', 'RHEV-Agent64 3.5.7', 'RHEV-Network64 3.5.2', 'RHEV-Block64 3.5.3', 'RHEV-SSO64 3.5.2', 'RHEV-Tools 3.5.10', 'RHEV-Balloo
n64 3.5.3', 'RHEV-SCSI64 3.5.2']
        guestOs = Win 8
        guestFQDN = DESKTOP-2A7IVG7.rhev.lab.eng.brq.redhat.com
        hash = 5295256131457450912
...
~~~

~~~
...
Dummy-1::INFO::2015-11-10 15:59:55,345::ovirtguestservice::94::root::Stopping OVirt Guest Agent service
Dummy-1::INFO::2015-11-10 16:00:48,424::ovirtguestservice::80::root::Starting OVirt Guest Agent service
Dummy-1::DEBUG::2015-11-10 16:00:48,424::ovirtagentlogic::162::root::AgentLogicBase:: __init__() entered
Dummy-1::DEBUG::2015-11-10 16:00:48,438::guestagentwin32::218::root::WinOsTypeHandler::getWinOsType osType = 'Win 8'
Dummy-1::DEBUG::2015-11-10 16:00:48,438::guestagentwin32::633::root::WinVdsAgent:: run() entered
Dummy-1::DEBUG::2015-11-10 16:00:48,517::ovirtagentlogic::186::root::AgentLogicBase:: run() entered
Dummy-2::DEBUG::2015-11-10 16:00:48,517::ovirtagentlogic::203::root::AgentLogicBase:: doWork() entered
Dummy-2::DEBUG::2015-11-10 16:00:48,517::ovirtagentlogic::249::root::AgentLogicBase::doListen() - entered
Dummy-2::DEBUG::2015-11-10 16:00:48,517::ovirtagentlogic::256::root::AgentLogicBase::doListen() - in loop before vio.read
Dummy-2::DEBUG::2015-11-10 16:00:48,627::guestagentwin32::495::root::Active user: user@DESKTOP-2A7IVG7
Dummy-2::DEBUG::2015-11-10 16:00:48,627::ovirtagentlogic::337::root::AgentLogicBase::sendUserInfo - cur_user = 'user@DESKTOP-2A7IVG7'
...
~~~

Version-Release number of selected component (if applicable):
RHEV-Agent64 3.5.7 / RHEV-toolsSetup_3.5_10.iso

How reproducible:
100%

Steps to Reproduce:
1. install WGT on either Win 10 32bit or 64 bit
2. check what guestOs is about
3.

Actual results:
windows 10 detected as windows 8

Expected results:
should be detected as windows 10

Additional info:
Comment 1 Michal Skrivanek 2015-11-13 08:05:02 EST
actually Windows 8.1 is already reported as "Windows 8"
Comment 2 Vinzenz Feenstra [evilissimo] 2015-11-25 04:06:22 EST
*** Bug 1279385 has been marked as a duplicate of this bug. ***
Comment 3 Vinzenz Feenstra [evilissimo] 2015-11-27 09:35:44 EST
Additional Note:

This BZ will also fix Win 2012R2 being reported as Win2012 and includes already the upcoming Win2016 Server
Comment 4 Michal Skrivanek 2015-12-17 05:10:13 EST
fixed in guest agent code
actual build is on integration team (lveyde)

Note You need to log in before you can comment on or make changes to this bug.