Bug 1279410 - dnf builddep fails with backtrace
dnf builddep fails with backtrace
Status: CLOSED DUPLICATE of bug 1272936
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 07:13 EST by Michael Adam
Modified: 2015-11-11 07:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-11 07:27:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Adam 2015-11-09 07:13:08 EST
Description of problem:

 dnf builddep does not work

Version-Release number of selected component (if applicable):

 dnf-plugins-core-0.1.13-1.fc23.noarch
 dnf-1.1.3-1.fc23.noarch

How reproducible:

 Always.

Steps to Reproduce:
1. run dnf builddep <sompackage>, e.g. dnf builddep samba

Actual results:

$ sudo dnf builddep samba
[sudo] password for obnox: 
enabling updates-source repository
enabling fedora-source repository
Fedora 23 - Source                                                                                                                                                                   1.2 MB/s | 5.9 MB     00:04    
Fedora 23 - Updates Source                                                                                                                                                           794 kB/s | 453 kB     00:00    
Last metadata expiration check performed 0:00:00 ago on Mon Nov  9 13:03:35 2015.
Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 136, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 76, in inner
    return func(*args, **kwds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 142, in run
    self._remote_deps(pkgspec)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 213, in _remote_deps
    package).get_best_query(self.base.sack)})
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 212, in <setcomp>
    for pkg in dnf.subject.Subject(
  File "/usr/lib/python3.4/site-packages/dnfpluginscore/lib.py", line 170, in package_source_name
    srcname = package.sourcerpm.rstrip(".src.rpm")
AttributeError: 'NoneType' object has no attribute 'rstrip'


Expected results:

It does not crash and instead installs build dependencies.

Additional info:
Comment 1 Michael Mráka 2015-11-11 07:27:11 EST

*** This bug has been marked as a duplicate of bug 1272936 ***

Note You need to log in before you can comment on or make changes to this bug.