Bug 1279413 - AttributeError: 'NoneType' object has no attribute 'mountpoints'
Summary: AttributeError: 'NoneType' object has no attribute 'mountpoints'
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 23
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e0430748bef6fabff3dc4f4c9ae...
: 1279658 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-11-09 12:21 UTC by Imran Hussain
Modified: 2016-04-24 21:30 UTC (History)
13 users (show)

Fixed In Version: anaconda-24.7-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-20 21:19:17 UTC


Attachments (Terms of Use)
File: anaconda-tb (280.28 KB, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: anaconda.log (5.93 KB, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: dnf.log (806 bytes, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: dnf.rpm.log (147 bytes, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: environ (459 bytes, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: ks.cfg (5.57 KB, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: lsblk_output (1.25 KB, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: nmcli_dev_list (1.36 KB, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: os_info (451 bytes, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: storage.log (103.78 KB, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: syslog (83.38 KB, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: ifcfg.log (2.08 KB, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: packaging.log (397 bytes, text/plain)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
File: program.log (44.30 KB, application/octet-stream)
2015-11-09 12:21 UTC, Imran Hussain
no flags Details
kickstarter config file (415 bytes, text/plain)
2015-11-15 15:15 UTC, Florian Apolloner
no flags Details
anaconda.log on beaker (11.81 KB, text/plain)
2015-11-26 09:48 UTC, Jiri Konecny
no flags Details

Description Imran Hussain 2015-11-09 12:21:03 UTC
Description of problem:


Version-Release number of selected component:
anaconda-23.19.10-1

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.4/site-packages/pyanaconda/packaging/dnfpayload.py", line 550, in spaceRequired
    for (key, val) in self.storage.mountpoints.items():
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/lib/space.py", line 76, in check
    needed = self.payload.spaceRequired
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/hubs/summary.py", line 79, in prompt
    if self._checker and not self._checker.check():
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 346, in _mainloop
    prompt = last_screen.prompt(self._screens[-1][1])
AttributeError: 'NoneType' object has no attribute 'mountpoints'

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   initrd=fedora/23/x86_64/initrd.img ks=nfs:137.44.10.1:/home/install/kickstart/kickstart23.cfg BOOT_IMAGE=fedora/23/x86_64/vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        23

Comment 1 Imran Hussain 2015-11-09 12:21:08 UTC
Created attachment 1091700 [details]
File: anaconda-tb

Comment 2 Imran Hussain 2015-11-09 12:21:09 UTC
Created attachment 1091701 [details]
File: anaconda.log

Comment 3 Imran Hussain 2015-11-09 12:21:11 UTC
Created attachment 1091702 [details]
File: dnf.log

Comment 4 Imran Hussain 2015-11-09 12:21:12 UTC
Created attachment 1091703 [details]
File: dnf.rpm.log

Comment 5 Imran Hussain 2015-11-09 12:21:13 UTC
Created attachment 1091704 [details]
File: environ

Comment 6 Imran Hussain 2015-11-09 12:21:15 UTC
Created attachment 1091705 [details]
File: ks.cfg

Comment 7 Imran Hussain 2015-11-09 12:21:16 UTC
Created attachment 1091706 [details]
File: lsblk_output

Comment 8 Imran Hussain 2015-11-09 12:21:18 UTC
Created attachment 1091707 [details]
File: nmcli_dev_list

Comment 9 Imran Hussain 2015-11-09 12:21:19 UTC
Created attachment 1091708 [details]
File: os_info

Comment 10 Imran Hussain 2015-11-09 12:21:21 UTC
Created attachment 1091709 [details]
File: storage.log

Comment 11 Imran Hussain 2015-11-09 12:21:23 UTC
Created attachment 1091710 [details]
File: syslog

Comment 12 Imran Hussain 2015-11-09 12:21:24 UTC
Created attachment 1091711 [details]
File: ifcfg.log

Comment 13 Imran Hussain 2015-11-09 12:21:26 UTC
Created attachment 1091712 [details]
File: packaging.log

Comment 14 Imran Hussain 2015-11-09 12:21:28 UTC
Created attachment 1091713 [details]
File: program.log

Comment 15 Imran Hussain 2015-11-09 12:35:54 UTC
PXE Booting to install Fedora 23 Workstation.

LABEL kickstart-23-workstation-x86_64
        MENU LABEL Install Fedora 23 Workstation (x86_64) Kickstart
        KERNEL fedora/23/x86_64/vmlinuz
        APPEND initrd=fedora/23/x86_64/initrd.img ks=nfs:137.44.10.1:/home/install/kickstart/kickstart23.cfg

vmlinuz and initrd.img taken from our mirror, http://mirror.sucs.org/pub/linux/fedora/releases/23/Workstation/x86_64/os/images/pxeboot/

Comment 16 Imran Hussain 2015-11-09 12:38:49 UTC
Possibly related to this https://bugzilla.redhat.com/show_bug.cgi?id=1276349 as well.

Comment 17 David Shea 2015-11-10 16:59:57 UTC
*** Bug 1279658 has been marked as a duplicate of this bug. ***

Comment 18 Adam Williamson 2015-11-10 17:12:17 UTC
Imran: The problem here is that anaconda is not successfully setting up the packaging spoke based on your kickstart; there's a bug whereby the TUI installer will crash (instead of leaving you at the hub and asking you to fix the problem, as it should) in that case.

I can't tell for sure as I can't see your kickstart, but it could very well be that you're hitting https://bugzilla.redhat.com/show_bug.cgi?id=1277638 - do you have a line in your kickstart something like:

repo --name=updates

i.e. a line which is just intended to enable a pre-defined repo by name? That's broken in F23, #1277638 is the bug for that (and there's an updates image linked from that bug which you can use to fix it).

Comment 19 Imran Hussain 2015-11-10 20:32:58 UTC
The kickstart script got uploaded to https://bugzilla.redhat.com/attachment.cgi?id=1091705

We have the following in our script:

repo --name=sucsmirror --baseurl="http://mirror.sucs.org/pub/linux/fedora/releases/23/Everything/x86_64/os" --install
repo --name=fedora --cost=10
repo --name=updates

I commented out:

repo --name=fedora --cost=10
repo --name=updates

It worked :)

Looking at the other bug I went and added inst.updates=https://fedorapeople.org/groups/qa/updates/1277638.img to our PXEBoot config and the install started fine with the repos uncommented :)

Sorry for not searching beforehand!

Comment 20 Adam Williamson 2015-11-11 02:45:14 UTC
This is a bug, please don't close it, we are working on fixing it. The bug is that the TUI installer should not crash when it encounters this situation.

Comment 21 Florian Apolloner 2015-11-15 15:15:21 UTC
Created attachment 1094466 [details]
kickstarter config file

I've added my ks.cfg, it does not contain any repo lines and I also run into this bug.

Comment 22 Adam Williamson 2015-11-20 21:19:17 UTC
24.7-1 was built yesterday, so I guess we can call this closed.

Comment 23 Jiri Konecny 2015-11-26 09:47:10 UTC
Another user experienced similar issue on beaker machine. I'll upload logs here.

This fix worked for him.

Comment 24 Jiri Konecny 2015-11-26 09:48:05 UTC
Created attachment 1099200 [details]
anaconda.log on beaker


Note You need to log in before you can comment on or make changes to this bug.