Bug 1279430 - cockpit-ws should be able to write to /run/cockpit-ws
cockpit-ws should be able to write to /run/cockpit-ws
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
23
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1283955
  Show dependency treegraph
 
Reported: 2015-11-09 08:00 EST by Stef Walter
Modified: 2015-11-26 15:57 EST (History)
7 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-155.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1283955 (view as bug list)
Environment:
Last Closed: 2015-11-26 15:57:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2015-11-09 08:00:37 EST
Description of problem:

Nov 09 07:53:45 localhost.localdomain kernel: type=1400 audit(1447073625.699:4): avc:  denied  { write } for  pid=2280 comm="ssh-transport-c" name="cockpit-ws" dev="tmpfs" ino=19561 scontext=system_u:system_r:cockpit_ws_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=dir

cockpit-ws should be able to write to a /run/cockpit-ws directory.

Version-Release number of selected component (if applicable):

selinux-policy-targeted-3.13.1-151.fc23.noarch
Comment 1 Daniel Walsh 2015-11-11 17:29:52 EST
Looks like new functionality.

https://github.com/fedora-selinux/selinux-policy/pull/64

Cockpit should really carry its own policy package similar to docker.
Comment 2 Stef Walter 2015-11-12 00:45:15 EST
(In reply to Daniel Walsh from comment #1)
> Looks like new functionality.

Yes, we are treating SELinux as any other dependency. First we get the API and changes we need from the lower level, before implementing the functionality in Cockpit.

> https://github.com/fedora-selinux/selinux-policy/pull/64

Commented on that pull request.

> Cockpit should really carry its own policy package similar to docker.

Even though using our own SELinux policy was a great way to get started ... it just started being problematic:

 1. Conflicts between the Cockpit SELinux policy and changes in the various
    Fedoras, mean that we would have had to carry a different SELinux policy
    for each targetted OS.

 2. Our testing used our custom SELinux policy and since users weren't installing
    it this led to false negatives, errors were hidden, and that's bad.
Comment 3 Miroslav Grepl 2015-11-12 05:09:44 EST
We will create a document/blog where we want to talk about experiences and about advices how to do it or not.

With new userspace (Fedora23+) there is no problem to ship a policy with the same name because we have priorities here. The problems come up with RHEL7 and old Fedoras.
Comment 5 Daniel Walsh 2015-11-12 08:57:34 EST
I am more concerned about RHEL then Fedora, since Fedora can have regular updates of selinux-policy it should not be a problem.  RHEL however will lag up to 6 months for an update.
Comment 6 Fedora Update System 2015-11-20 08:15:48 EST
selinux-policy-3.13.1-155.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-0d84d6c75f
Comment 7 Fedora Update System 2015-11-22 09:25:58 EST
selinux-policy-3.13.1-155.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update selinux-policy'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-0d84d6c75f
Comment 8 Fedora Update System 2015-11-26 15:57:17 EST
selinux-policy-3.13.1-155.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.