Bug 1283955 - cockpit-ws should be able to write to /run/cockpit-ws
cockpit-ws should be able to write to /run/cockpit-ws
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
:
Depends On: 1279430
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-20 06:37 EST by Miroslav Grepl
Modified: 2016-11-03 22:24 EDT (History)
13 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-80.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1279430
Environment:
Last Closed: 2016-11-03 22:24:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Grepl 2015-11-20 06:37:53 EST
+++ This bug was initially created as a clone of Bug #1279430 +++

Description of problem:

Nov 09 07:53:45 localhost.localdomain kernel: type=1400 audit(1447073625.699:4): avc:  denied  { write } for  pid=2280 comm="ssh-transport-c" name="cockpit-ws" dev="tmpfs" ino=19561 scontext=system_u:system_r:cockpit_ws_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=dir

cockpit-ws should be able to write to a /run/cockpit-ws directory.

Version-Release number of selected component (if applicable):

selinux-policy-targeted-3.13.1-151.fc23.noarch

--- Additional comment from Daniel Walsh on 2015-11-11 17:29:52 EST ---

Looks like new functionality.

https://github.com/fedora-selinux/selinux-policy/pull/64

Cockpit should really carry its own policy package similar to docker.

--- Additional comment from Stef Walter on 2015-11-12 00:45:15 EST ---

(In reply to Daniel Walsh from comment #1)
> Looks like new functionality.

Yes, we are treating SELinux as any other dependency. First we get the API and changes we need from the lower level, before implementing the functionality in Cockpit.

> https://github.com/fedora-selinux/selinux-policy/pull/64

Commented on that pull request.

> Cockpit should really carry its own policy package similar to docker.

Even though using our own SELinux policy was a great way to get started ... it just started being problematic:

 1. Conflicts between the Cockpit SELinux policy and changes in the various
    Fedoras, mean that we would have had to carry a different SELinux policy
    for each targetted OS.

 2. Our testing used our custom SELinux policy and since users weren't installing
    it this led to false negatives, errors were hidden, and that's bad.

--- Additional comment from Miroslav Grepl on 2015-11-12 05:09:44 EST ---

We will create a document/blog where we want to talk about experiences and about advices how to do it or not.

With new userspace (Fedora23+) there is no problem to ship a policy with the same name because we have priorities here. The problems come up with RHEL7 and old Fedoras.

--- Additional comment from Miroslav Grepl on 2015-11-12 05:36:53 EST ---

https://github.com/fedora-selinux/selinux-policy/commit/6d37ae059db8a2d2974215f452864f6cb6e4895e

--- Additional comment from Daniel Walsh on 2015-11-12 08:57:34 EST ---

I am more concerned about RHEL then Fedora, since Fedora can have regular updates of selinux-policy it should not be a problem.  RHEL however will lag up to 6 months for an update.
Comment 5 errata-xmlrpc 2016-11-03 22:24:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html

Note You need to log in before you can comment on or make changes to this bug.