Bug 1279458 - Container Image Analysis Tasks should not be categorized as VM Analysis Tasks
Container Image Analysis Tasks should not be categorized as VM Analysis Tasks
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Erez Freiberger
Einat Pacifici
container:smartstate:ui:task
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 08:46 EST by Jan Krocil
Modified: 2016-06-29 11:05 EDT (History)
15 users (show)

See Also:
Fixed In Version: 5.6.0.1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:05:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 14:50:04 EDT

  None (edit)
Description Jan Krocil 2015-11-09 08:46:49 EST
Description of problem:
SSIA

Version-Release number of selected component (if applicable):
5.5.0.9

How reproducible:
Always

Steps to Reproduce:
1. Start a smartstate analysis of a container image
2. Go to Config > Tasks > All Other Tasks

Actual results:
No container image SSA task is present.

Expected results:
Container image SSA task is present.

Additional info:
-
Comment 2 Daniel Korn 2015-11-16 07:36:18 EST
The smartstate analysis task of a container image is displayed under "All VM Analysis Tasks" (Config > Tasks > All VM Analysis Tasks). 

IMHO, that's the right place to present these tasks since afaik they fall under 'analysis' tasks category, rather than 'ui' jobs (displayed in "All Other Tasks").
Comment 3 Harpreet Kataria 2015-11-17 12:50:44 EST
Daniel,

Looked at Tasks screen, on My/All VM Analysis Tasks screen data comes from 'jobs' table that i think only has Smartstate Analysis records only. My/All UI Tasks tabs are populated with data from 'miq_tasks' table that has all other UI tasks that are queued. So Container Image Smartstate Analysis tasks should show up on Analysis Tasks tabs. Let me know if you have any further questions.

Thanks,
~Harpreet
Comment 4 Daniel Korn 2015-11-18 04:21:02 EST
Thanks for the clarification Harpreet.

So, as I wrote in my last comment, I don't think this should be considered a bug since the tasks are shown in Analysis tab.
Does anyone thinks otherwise?
Comment 5 Thom Carlin 2015-11-18 06:58:12 EST
I think we should change the tab title to "My/All SmartState Analysis Tasks" since this would also solve the click-through problem described in https://bugzilla.redhat.com/show_bug.cgi?id=1274375.
Comment 7 Federico Simoncelli 2015-12-16 09:30:33 EST
(In reply to Thom Carlin from comment #5)
> I think we should change the tab title to "My/All SmartState Analysis Tasks"
> since this would also solve the click-through problem described in
> https://bugzilla.redhat.com/show_bug.cgi?id=1274375.

Agreed.

Thom, in case nobody else already addressed this, we'll handle the renaming of "My SmartState Analysis Tasks" => "All SmartState Analysis Tasks" in this BZ.
Comment 8 Thom Carlin 2015-12-28 09:00:37 EST
Excellent, thanks!
Comment 10 Federico Simoncelli 2016-04-22 10:27:10 EDT
Fixed with:  https://github.com/ManageIQ/manageiq/pull/5880
Comment 11 Einat Pacifici 2016-05-15 07:12:37 EDT
Container image task now shows up in tab that has been renamed to:"All VM Analysis Tasks"
Comment 12 Lucy Bopf 2016-05-17 00:38:14 EDT
It appears that this bug should no longer be documented as a known issue. Removing doc text and resetting requires_doc_text flag.
Comment 14 errata-xmlrpc 2016-06-29 11:05:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.