Bug 1279548 - [upgrade] broker.conf got overwritten with initial defaults during 3.5 -> 3.6 upgrade
[upgrade] broker.conf got overwritten with initial defaults during 3.5 -> 3.6...
Status: CLOSED CURRENTRELEASE
Product: ovirt-hosted-engine-ha
Classification: oVirt
Component: Packaging.rpm (Show other bugs)
1.3.2.1
Unspecified Unspecified
unspecified Severity urgent (vote)
: ovirt-3.6.1
: 1.3.3
Assigned To: Simone Tiraboschi
Artyom
integration
: Triaged
Depends On:
Blocks: ovirt-hosted-engine-ha-1.3.4.3 RHEV3.6Upgrade
  Show dependency treegraph
 
Reported: 2015-11-09 12:13 EST by Simone Tiraboschi
Modified: 2017-01-23 21:35 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:19:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
bmcclain: planning_ack+
sbonazzo: devel_ack+
istein: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48315 master MERGED packaging: ensuring it saves broker.conf during upgrades Never
oVirt gerrit 48352 ovirt-hosted-engine-ha-1.3 MERGED packaging: ensuring it saves broker.conf during upgrades Never

  None (edit)
Description Simone Tiraboschi 2015-11-09 12:13:24 EST
Description of problem:
in 3.6 broker.conf got moved to the shared storage and periodically copied to /var/lib/ovirt-hosted-engine-ha/broker.conf for caching purposes and to be able to send notification also when the shared storage goes down; during a 3.5 -> 3.6 upgrade, broker.conf got overwritten with initial defaults


Version-Release number of selected component (if applicable):
1.3.1.2

How reproducible:
100%

Steps to Reproduce:
1. upgrade form 3.5 to 3.6
2. check /var/lib/ovirt-hosted-engine-ha/broker.conf 
3.

Actual results:
broker.conf on the shared storage got written with the initial defaults

Expected results:
broker.conf on the shared storage got written with the values it had just before the upgrade.

Additional info:

Ho to fix the copy on the shared storage if it's already happened:
dir=`mktemp -d` && cd $dir
systemctl stop ovirt-ha-broker
sdUUID_line=$(grep sdUUID /etc/ovirt-hosted-engine/hosted-engine.conf)
sdUUID=${sdUUID_line:7:36}
conf_volume_UUID_line=$(grep conf_volume_UUID /etc/ovirt-hosted-engine/hosted-engine.conf)
conf_volume_UUID=${conf_volume_UUID_line:17:36}
conf_image_UUID_line=$(grep conf_image_UUID /etc/ovirt-hosted-engine/hosted-engine.conf)
conf_image_UUID=${conf_image_UUID_line:16:36}
dd if=/rhev/data-center/mnt/192.168.1.115:_Virtual_ext35u36/$sdUUID/images/$conf_image_UUID/$conf_volume_UUID 2>/dev/null| tar -xvf -
cp /etc/ovirt-hosted-engine-ha/broker.conf.rpmsave broker.conf # or edit broker.conf as you need 
tar -cO * | dd of=/rhev/data-center/mnt/192.168.1.115:_Virtual_ext35u36/$sdUUID/images/$conf_image_UUID/$conf_volume_UUID
systemctl start ovirt-ha-broker
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-09 12:23:29 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-09 12:23:29 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 3 Artyom 2015-12-08 08:57:38 EST
Verified on ovirt-hosted-engine-ha-1.3.3.1-1.el7ev.noarch
After upgrade of packages and restart /var/lib/ovirt-hosted-engine-ha/broker.conf content equal to /etc/ovirt-hosted-engine-ha/broker.conf in 3.5
Comment 4 Sandro Bonazzola 2015-12-16 07:19:06 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.