Bug 1279554 - Missing Ceph configuration options
Missing Ceph configuration options
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-tripleo (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 10.0 (Newton)
Assigned To: Giulio Fidente
Yogev Rabl
: Triaged
Depends On:
Blocks: 1299836
  Show dependency treegraph
 
Reported: 2015-11-09 12:35 EST by Ben Nemec
Modified: 2016-12-14 10:16 EST (History)
10 users (show)

See Also:
Fixed In Version: puppet-tripleo-5.2.0-1.el7ost
Doc Type: Enhancement
Doc Text:
Using the RBD backend driver (Ceph Storage) for OpenStack Compute (nova) ephemeral disks applies two additional settings to libvirt: hw_disk_discard : unmap disk_cachemodes : network=writeback This allows reclaiming of unused blocks on the Ceph pool and caching of network writes, which improves the performance for OpenStack Compute ephemeral disks using the RBD driver. Also see http://docs.ceph.com/docs/master/rbd/rbd-openstack/
Story Points: ---
Clone Of:
: 1299836 (view as bug list)
Environment:
Last Closed: 2016-12-14 10:16:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 269561 None None None 2016-01-19 06:19 EST

  None (edit)
Description Ben Nemec 2015-11-09 12:35:44 EST
Description of problem: According to the Ceph documentation at http://docs.ceph.com/docs/master/rbd/rbd-openstack/ there are some additional Nova options we should be setting when using Ceph as the backend.  I don't see any references to these params in our templates, so they were probably just missed in the initial Ceph implementation.

Two in particular that were noticed when documenting external Ceph are:

disk_cachemodes
hw_disk_discard

It doesn't seem that either of these are required for Ceph to function as the Nova backend, but it may be performing suboptimally when they're not set correctly.
Comment 3 Mike Burns 2016-04-07 16:57:01 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Giulio Fidente 2016-07-19 07:09:37 EDT
Moving into POST as this was merged upstream
Comment 8 Yogev Rabl 2016-10-13 06:55:03 EDT
verified on puppet-tripleo-5.2.0-1.el7ost.noarch
Comment 10 errata-xmlrpc 2016-12-14 10:16:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html

Note You need to log in before you can comment on or make changes to this bug.