Bug 1279589 - Incorrect type usage of extension api
Incorrect type usage of extension api
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Extension-API (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Yaniv Kaul
Pavel Stehlik
: CodeChange
Depends On:
Blocks: 1280246
  Show dependency treegraph
 
Reported: 2015-11-09 14:55 EST by Alon Bar-Lev
Modified: 2016-07-27 09:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1280246 (view as bug list)
Environment:
Last Closed: 2016-07-27 09:00:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
rule-engine: planning_ack+
alonbl: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48314 master MERGED aaa: AVAILABLE_NAMESPACES are Collection<String> per api spec Never
oVirt gerrit 48318 master MERGED extapi: extmap: do not cast to default type class Never
oVirt gerrit 48422 ovirt-engine-3.6 MERGED extapi: extmap: do not cast to default type class Never
oVirt gerrit 48423 ovirt-engine-3.6 MERGED aaa: AVAILABLE_NAMESPACES are Collection<String> per api spec Never

  None (edit)
Description Alon Bar-Lev 2015-11-09 14:55:37 EST
1. ExtMap.get tries to cast to default value type.
2. AVAILABLE_NAMESPACES is a collection not a list.
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-09 14:55:41 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-09 14:59:12 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 5 Ondra Machacek 2016-02-25 04:39:19 EST
This one shouldn't be ON_QA, because there is no 4.0 build for QE, yet.
Comment 7 Gil Klein 2016-07-27 09:00:07 EDT
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.