Bug 1280246 - Incorrect type usage of extension api
Incorrect type usage of extension api
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Extension-API (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.6.3
: 3.6.1
Assigned To: Yaniv Kaul
Ondra Machacek
: CodeChange, ZStream
Depends On: 1279589
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 05:32 EST by Alon Bar-Lev
Modified: 2016-02-18 06:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1279589
Environment:
Last Closed: 2016-02-18 06:17:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: planning_ack+
alonbl: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48314 None None None Never
oVirt gerrit 48318 None None None Never
oVirt gerrit 48422 ovirt-engine-3.6 MERGED extapi: extmap: do not cast to default type class Never
oVirt gerrit 48423 ovirt-engine-3.6 MERGED aaa: AVAILABLE_NAMESPACES are Collection<String> per api spec Never

  None (edit)
Description Alon Bar-Lev 2015-11-11 05:32:48 EST
+++ This bug was initially created as a clone of Bug #1279589 +++

1. ExtMap.get tries to cast to default value type.
2. AVAILABLE_NAMESPACES is a collection not a list.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-09 14:55:41 EST ---

Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2015-11-09 14:59:12 EST ---

Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-11 05:32:52 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Note You need to log in before you can comment on or make changes to this bug.