Bug 1279607 - [RFE] support override of API and RPC worker counts
[RFE] support override of API and RPC worker counts
Status: CLOSED DUPLICATE of bug 1282429
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Jiri Stransky
yeylon@redhat.com
: FutureFeature
Depends On: 1269622 1282429
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 15:51 EST by Brent Eagles
Modified: 2016-04-18 03:01 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.8-1.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1269622
Environment:
Last Closed: 2016-02-25 06:48:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 229471 None None None Never

  None (edit)
Description Brent Eagles 2015-11-09 15:51:04 EST
+++ This bug was initially created as a clone of Bug #1269622 +++

Description of problem:

Currently, the API and RPC worker counts are calculated to match the number of processors. Given that multiple components support multiple worker processes for different services, this can result in a lot of processes depending on the node role. Providing the ability to control the worker counts would allow purpose-driven tuning.

--- Additional comment from Brent Eagles on 2015-10-13 12:01:27 EDT ---

The relevant configuration items are found in /etc/neutron.conf and they are:

api_workers = [integer value >= 0] 
rpc_workers = [integer value >= 0]

for kilo: 0 means no separate process for worker threads
Comment 4 Mike Burns 2016-02-25 06:48:41 EST

*** This bug has been marked as a duplicate of bug 1282429 ***

Note You need to log in before you can comment on or make changes to this bug.