Bug 1282429 - [RFE] support override of API and RPC worker counts
[RFE] support override of API and RPC worker counts
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: ga
: 8.0 (Liberty)
Assigned To: Jiri Stransky
Amit Ugol
: FutureFeature, TestOnly
: 1279607 (view as bug list)
Depends On: 1269622
Blocks: 1279607
  Show dependency treegraph
 
Reported: 2015-11-16 06:38 EST by Nir Yechiel
Modified: 2016-04-28 09:51 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.8-1.el7ost
Doc Type: Enhancement
Doc Text:
This update adds new parameters to configure API worker process counts, which allows you to tune overcloud's memory utilization and request processing capacity. The parameters are: CeilometerWorkers, CinderWorkers, GlanceWorkers, HeatWorkers, KeystoneWorkers, NeutronWorkers, NovaWorkers, and SwiftWorkers.
Story Points: ---
Clone Of: 1269622
Environment:
Last Closed: 2016-04-28 09:51:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 229471 None None None Never

  None (edit)
Description Nir Yechiel 2015-11-16 06:38:17 EST
+++ This bug was initially created as a clone of Bug #1269622 +++

Description of problem:

Currently, the API and RPC worker counts are calculated to match the number of processors. Given that multiple components support multiple worker processes for different services, this can result in a lot of processes depending on the node role. Providing the ability to control the worker counts would allow purpose-driven tuning.

--- Additional comment from Brent Eagles on 2015-10-13 12:01:27 EDT ---

The relevant configuration items are found in /etc/neutron.conf and they are:

api_workers = [integer value >= 0] 
rpc_workers = [integer value >= 0]

for kilo: 0 means no separate process for worker threads
Comment 3 Mike Burns 2016-02-25 06:48:41 EST
*** Bug 1279607 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.