Bug 1279655 - [abrt] rpmconf: filecmp.py:51:cmp:FileNotFoundError: [Errno 2] No such file or directory: '/etc/mock/default.cfg'
[abrt] rpmconf: filecmp.py:51:cmp:FileNotFoundError: [Errno 2] No such file o...
Status: CLOSED DUPLICATE of bug 1277025
Product: Fedora
Classification: Fedora
Component: rpmconf (Show other bugs)
22
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6d891bf9135aa52200288c9878a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 19:01 EST by Timothy Ward
Modified: 2015-11-22 08:25 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-22 08:25:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (897 bytes, text/plain)
2015-11-09 19:01 EST, Timothy Ward
no flags Details
File: environ (2.14 KB, text/plain)
2015-11-09 19:01 EST, Timothy Ward
no flags Details

  None (edit)
Description Timothy Ward 2015-11-09 19:01:08 EST
Version-Release number of selected component:
rpmconf-1.0.12-1.fc22

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 /sbin/rpmconf -a
executable:     /sbin/rpmconf
kernel:         4.1.6-201.fc22.i686+PAE
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
filecmp.py:51:cmp:FileNotFoundError: [Errno 2] No such file or directory: '/etc/mock/default.cfg'

Traceback (most recent call last):
  File "/sbin/rpmconf", line 63, in <module>
    main()
  File "/sbin/rpmconf", line 60, in main
    rconf.run()
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 90, in run
    self._handle_package(pkg_hdr)
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 264, in _handle_package
    tmp.format(conf_file, "rpmnew"))
  File "/usr/lib/python3.4/site-packages/rpmconf/rpmconf.py", line 273, in _handle_rpmnew
    if filecmp.cmp(conf_file, other_file):
  File "/usr/lib/python3.4/filecmp.py", line 51, in cmp
    s1 = _sig(os.stat(f1))
FileNotFoundError: [Errno 2] No such file or directory: '/etc/mock/default.cfg'

Local variables in innermost frame:
shallow: True
f1: '/etc/mock/default.cfg'
f2: '/etc/mock/default.cfg.rpmnew'
Comment 1 Timothy Ward 2015-11-09 19:01:13 EST
Created attachment 1092022 [details]
File: backtrace
Comment 2 Timothy Ward 2015-11-09 19:01:15 EST
Created attachment 1092023 [details]
File: environ
Comment 3 Timothy Ward 2015-11-19 01:37:10 EST
This fails even when rpmconf is run under root access.
Comment 4 Miroslav Suchý 2015-11-22 08:25:27 EST

*** This bug has been marked as a duplicate of bug 1277025 ***

Note You need to log in before you can comment on or make changes to this bug.