Bug 1277025 - rpmconf handles symlinks poorly
rpmconf handles symlinks poorly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmconf (Show other bugs)
22
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
: 1279496 1279655 1285477 1303934 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 00:45 EST by Christopher Tubbs
Modified: 2016-02-02 13:35 EST (History)
7 users (show)

See Also:
Fixed In Version: rpmconf-1.0.16-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 15:28:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Tubbs 2015-11-02 00:45:59 EST
Description of problem:
ran `rpmconf -a` after updating mock with normal dnf upgrade and got a python stack trace because /etc/mock/default.cfg and /etc/mock/default.cfg.rpmnew were both symlinks

Version-Release number of selected component (if applicable):
rpmconf-1.0.12-1.fc22.noarch

How reproducible:
Always

Steps to Reproduce:
1. dnf upgrade mock to mock-1.2.13-2.fc22.noarch from previous version.
2. rpmconf -a

Actual results:
Stack trace with error message about /etc/mock/default.cfg not existing. Program terminated abnormally.

Expected results:
Program should prompt to address /etc/mock/default.cfg and /etc/mock/default.cfg.rpmnew

Additional info:
Comment 1 Miroslav Suchý 2015-11-22 08:25:20 EST
*** Bug 1279496 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Suchý 2015-11-22 08:25:27 EST
*** Bug 1279655 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Suchý 2015-11-26 09:48:31 EST
*** Bug 1285477 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Suchý 2015-11-27 02:53:32 EST
Fixed in commit:
* fef3024 (HEAD -> master, origin/master) 1277025 - handle broken symlinks
Comment 5 Fedora Update System 2015-11-30 05:03:35 EST
rpmconf-1.0.15-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd
Comment 6 Fedora Update System 2015-11-30 21:22:51 EST
rpmconf-1.0.15-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmconf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd
Comment 7 Fedora Update System 2015-12-01 07:24:08 EST
rpmconf-1.0.16-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd
Comment 8 Fedora Update System 2015-12-01 17:31:22 EST
rpmconf-1.0.16-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmconf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-8588d401cd
Comment 9 Fedora Update System 2015-12-07 15:28:26 EST
rpmconf-1.0.16-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 10 Miroslav Suchý 2016-02-02 13:35:41 EST
*** Bug 1303934 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.