Bug 1279671 - dnf upgrade download step fails "No such command: system-upgrade" but LANG=en_US.UTF-8
dnf upgrade download step fails "No such command: system-upgrade" but LANG=en...
Status: CLOSED DUPLICATE of bug 1280240
Product: Fedora
Classification: Fedora
Component: dnf-plugin-system-upgrade (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 21:15 EST by Richard L. England
Modified: 2015-11-14 11:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-14 11:53:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard L. England 2015-11-09 21:15:47 EST
Description of problem: 
dnf system-upgrade plugin is not recognized by dnf after installation. NOT the LANG!=en* problem, LANG=en_US.UTF-8 is set

# dnf install dnf-plugin-system-upgrade

Last metadata expiration check performed 0:10:14 ago on Thu Nov 5 21:26:38 2015.
Package dnf-plugin-system-upgrade-0.7.0-1.fc22.noarch is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

But it does not seem to be available.

# dnf system-upgrade download –releasever 23

No such command: system-upgrade. Please use /usr/bin/dnf –help
It could be a DNF plugin command, try: “dnf install ‘dnf-command(system-upgrade)'”

The alternative install appears to works as well.

# dnf install ‘dnf-command(system-upgrade)’

Last metadata expiration check performed 0:06:35 ago on Thu Nov 5 21:50:16 2015.
Package dnf-plugin-system-upgrade-0.7.0-1.fc22.noarch is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!

But after that the down load step still fails. I have successfully un-installed the plug in and re-installed but with the same results. It acts like the plugin is not detected.


Version-Release number of selected component (if applicable):
dnf-plugin-system-upgrade-0.7.0-1.fc22.noarch
python2-dnf-plugin-system-upgrade-0.7.0-1.fc22.noarch

# uname -a
Linux poirot.net 4.2.5-201.fc22.x86_64 #1 SMP Wed Oct 28 20:00:23 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux



How reproducible:
On a single system this occurs every time 

Steps to Reproduce:
(see above)

Actual results:
The following messsage is returned -

No such command: system-upgrade. Please use /usr/bin/dnf –help
It could be a DNF plugin command, try: “dnf install ‘dnf-command(system-upgrade)'”


Expected results:
Download step should proceed to download the ~4000 update items.

Additional info:
'dnf update' was run just before the attempt to upgrade (several times).

This system has been updated several time from ~F16, lately using fedup, with no issues. 

# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8
Comment 1 Will Woods 2015-11-11 10:39:42 EST
Could you attach a list of your installed DNF packages?
(Just do 'rpm -qa | grep dnf | sort' to get a list..)

This looks like it might be the same problem as bug 1280240 - I'm guessing your system might be using the python3 dnf for /usr/bin/dnf somehow, which doesn't work because you don't have python3-dnf-plugin-system-upgrade installed.

So, two more questions:

1) Does it work if you do 'dnf-2 system-upgrade'?
2) Did you do something to set up your system to use python3-dnf by default?
Comment 2 Richard L. England 2015-11-12 23:00:34 EST
Tried dnf-2 with the same results

# dnf-2 system-upgrade download --releasever=23
No such command: system-upgrade. Please use /usr/bin/dnf-2 --help
It could be a DNF plugin command, try: "dnf install 'dnf-command(system-upgrade)'"

Python is version as far as python is reporting.

# python --version
Python 2.7.10

dnf listing

# rpm -qa | grep dnf | sort
dnf-1.1.3-1.fc22.noarch
dnf-conf-1.1.3-1.fc22.noarch
dnfdaemon-0.3.8-1.fc22.noarch
dnf-langpacks-0.15.1-1.fc22.noarch
dnf-langpacks-conf-0.15.1-1.fc22.noarch
dnf-plugins-core-0.1.13-1.fc22.noarch
dnf-plugin-system-upgrade-0.7.0-1.fc22.noarch
dnf-yum-1.1.3-1.fc22.noarch
python2-dnf-plugin-system-upgrade-0.7.0-1.fc22.noarch
python3-dnf-1.1.3-1.fc22.noarch
python3-dnfdaemon-0.3.8-1.fc22.noarch
python-dnf-1.1.3-1.fc22.noarch
python-dnf-langpacks-0.15.1-1.fc22.noarch
python-dnf-plugins-core-0.1.13-1.fc22.noarch
python-dnf-plugins-extras-common-0.0.11-1.fc22.noarch
python-dnf-plugins-extras-migrate-0.0.11-1.fc22.noarch
yumex-dnf-4.1.2-1.fc22.noarch
Comment 3 Will Woods 2015-11-13 10:12:35 EST
..do you, by any chance, have `plugins=0` or similar in your dnf.conf?
(See bug 1280240, again)
Comment 4 Richard L. England 2015-11-14 02:04:12 EST
Bingo! 

Yes dnf.conf contained the line 'plugins=0'.  I changed that to 'plugins=1' and the download is now working.

To the best of my knowledge I have not modified anything in /etc/dnf, at least not by manually editing anything.

Thank you for your persistence, and promptness.
Comment 5 Zbigniew Jędrzejewski-Szmek 2015-11-14 11:53:36 EST

*** This bug has been marked as a duplicate of bug 1280240 ***

Note You need to log in before you can comment on or make changes to this bug.