Bug 1280240 - dnf should warn if plugins are disabled and an unknown command is requested
dnf should warn if plugins are disabled and an unknown command is requested
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Michal Luscon
: FutureFeature, Reopened
: 1279671 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 05:11 EST by Stefan Assmann
Modified: 2016-01-04 14:52 EST (History)
9 users (show)

See Also:
Fixed In Version: dnf-1.1.5-1.fc23 dnf-1.1.5-1.fc22
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 16:59:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Assmann 2015-11-11 05:11:12 EST
Description of problem:
System has been updated to the latest and greatest f22 but I still cannot update to f23.

# dnf system-upgrade download --releasever=23
No such command: system-upgrade. Please use /bin/dnf --help
It could be a DNF plugin command, try: "dnf install 'dnf-command(system-upgrade)'"
# fedup --network 23
No such command: system-upgrade. Please use /usr/bin/dnf --help
It could be a DNF plugin command, try: "dnf install 'dnf-command(system-upgrade)'"

Version-Release number of selected component (if applicable):
[root@t530 ~]# rpm -qa |grep dnf
python-dnf-langpacks-0.15.1-1.fc22.noarch
python-dnf-plugins-core-0.1.13-1.fc22.noarch
python3-dnf-1.1.3-1.fc22.noarch
dnf-1.1.3-1.fc22.noarch
dnf-conf-1.1.3-1.fc22.noarch
python2-dnf-plugin-system-upgrade-0.7.0-1.fc22.noarch
python-dnf-plugins-extras-common-0.0.11-1.fc22.noarch
dnf-yum-1.1.3-1.fc22.noarch
dnf-langpacks-conf-0.15.1-1.fc22.noarch
python-dnf-plugins-extras-migrate-0.0.11-1.fc22.noarch
dnf-plugins-core-0.1.13-1.fc22.noarch
dnf-langpacks-0.15.1-1.fc22.noarch
python-dnf-1.1.3-1.fc22.noarch
dnf-plugin-system-upgrade-0.7.0-1.fc22.noarch

How reproducible:
always
Comment 1 Will Woods 2015-11-11 10:33:39 EST
You've got both the python2 and python3 DNF versions installed, but only python2-dnf-plugin-system-upgrade. Maybe your system is (somehow) using the python3 version of DNF by default?

Does it work if you try "dnf-2 system-upgrade download --releasever=23", or if you install python3-dnf-plugin-system-upgrade?
Comment 2 Stefan Assmann 2015-11-11 10:58:54 EST
# dnf-2 system-upgrade download --releasever=23
No such command: system-upgrade. Please use /bin/dnf-2 --help
It could be a DNF plugin command, try: "dnf install 'dnf-command(system-upgrade)'"

Let me know which RPMs I should de-install and I'll give it a try.
Comment 3 Stefan Assmann 2015-11-11 11:14:53 EST
Also tried installing python3-dnf-plugin-system-upgrade, didn't help either. Sorry I forgot to mention that.
Comment 4 Will Woods 2015-11-11 17:54:40 EST
Hrm. Well, I'm not sure how to debug dnf's plugin loader further, so I'm reassigning this to dnf.
Comment 5 Stefan Assmann 2015-11-13 09:00:06 EST
ok, I found plugins=0 in my dnf.conf. I can't remember putting it there. Sorry for the noise.

Anyway, as a RFE could we print a warning if plugins are disabled and somebody tries to use a plugin? Thanks for considering!
Comment 6 Zbigniew Jędrzejewski-Szmek 2015-11-14 11:53:36 EST
*** Bug 1279671 has been marked as a duplicate of this bug. ***
Comment 7 Michal Luscon 2015-11-18 08:47:14 EST
Unfortunately, plugin name check would require loading of plugins.
Comment 8 Zbigniew Jędrzejewski-Szmek 2015-11-18 08:50:49 EST
No, not really.

I'm asking for the text
"""
It could be a DNF plugin command, try: "dnf install 'dnf-command(system-upgrade)'"
"""
to be changed to something like
"""
If could be a DNF plugin command, but plugin loading is currently disabled.
"""
when plugins=0.
Comment 9 Fedora Update System 2015-12-18 12:46:34 EST
dnf-plugins-core-0.1.15-1.fc23 dnf-1.1.5-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c72cd24fa0
Comment 10 Fedora Update System 2015-12-18 12:48:25 EST
dnf-plugins-core-0.1.15-1.fc22 dnf-1.1.5-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1bb112ccc6
Comment 11 Fedora Update System 2015-12-19 14:59:19 EST
dnf-1.1.5-1.fc23, dnf-plugins-core-0.1.15-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf dnf-plugins-core'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c72cd24fa0
Comment 12 Fedora Update System 2015-12-22 10:35:01 EST
dnf-1.1.5-1.fc22, dnf-plugins-core-0.1.15-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1bb112ccc6
Comment 13 Fedora Update System 2015-12-22 16:58:35 EST
dnf-1.1.5-1.fc23, dnf-plugins-core-0.1.15-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2016-01-04 14:51:52 EST
dnf-1.1.5-1.fc22, dnf-plugins-core-0.1.15-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.