Bug 127972 - Nano doesn't scroll correctly
Nano doesn't scroll correctly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Woodhouse
:
: 138726 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-15 16:52 EDT by Michael McCabe
Modified: 2007-11-30 17:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-11 06:29:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Nano with text file opened before scrolling (100.70 KB, image/png)
2004-07-15 16:54 EDT, Michael McCabe
no flags Details
Nano after scrolling (103.89 KB, image/png)
2004-07-15 16:55 EDT, Michael McCabe
no flags Details

  None (edit)
Description Michael McCabe 2004-07-15 16:52:39 EDT
Description of problem:
When scrolling up and down the screen in nano not all of the screen
scrolls.  (See two attached screenshots). 

Version-Release number of selected component (if applicable):
nano-1.2.3-2

How reproducible:
Everytime

Steps to Reproduce:
1.Open nano in a gnome-terminal
2.Scroll up and down the screen for more text using the keyboard.
3.The text doesn't scroll correctly.  
  
Actual results:
Text doesn't scroll correctly.

Expected results:
Test scrolls correctly

Additional info:
Comment 1 Michael McCabe 2004-07-15 16:54:18 EDT
Created attachment 101945 [details]
Nano with text file opened before scrolling
Comment 2 Michael McCabe 2004-07-15 16:55:03 EDT
Created attachment 101946 [details]
Nano after scrolling
Comment 3 Bill Nottingham 2004-08-05 14:38:33 EDT
What is your TERM set to?
Comment 4 Michael McCabe 2004-08-05 20:34:05 EDT
xterm
Comment 5 Jef Spaleta 2004-09-07 12:06:43 EDT
I'm seeing this as well on my development box
nano-1.2.4-1
$TERM  xterm

As a comparison nano on fc2 does not exhibit this problem.
nano-1.2.3-1
$TERM xterm

So i installed nano-1.2.3-1 on my development box,
and I see the problem. 

And on installing nano-1.2.4-1 on my fc2 box i do not see the problem.

Not sure where the problem is, but its not
something introduced in nano-1.2.4-1.

Any pointers at what the deeper problem is?
-jef
Comment 6 Tom "spot" Callaway 2004-09-16 15:02:23 EDT
This problem does not seem to happen while using xterm, just
gnome-terminal. I am very suspicious of gnome-terminal.
Comment 7 Tom "spot" Callaway 2004-09-16 15:45:11 EDT
Also, it seems to be specific to arrow scrolling, page up-down does
not seem to cause corruption.
Comment 8 Jef Spaleta 2004-09-19 13:18:59 EDT
Is this a change in termcap perhaps that gnome-terminal doesnt like?

Ive tested  
fc2 gnome terminal ssh into development box... problem
fc2 gnome terminal ssh into other fc2 box ... fine
develment box gnome terminal ssh into fc2 box .. fine

did something get changed in the xterm definition in termcap in the
development tree?

-jef
Comment 9 Tom "spot" Callaway 2004-10-06 10:08:38 EDT
Jef, I think this is almost definitely the case, since changing TERM
to linux makes nano start working again.
Comment 10 Per Bjornsson 2004-11-11 13:57:48 EST
Yes, this does seem to be a vte bug. I think it's fixed in
vte-0.11.11-13 (current in Rawhide on 2004-11-11); at least I can no
longer reproduce it. (Just tested quickly though.)
Comment 11 Marcus Grando 2004-11-14 22:15:01 EST
vte-0.11.11-13 show correct text for me.
Comment 12 Trevor Cordes 2004-11-15 06:17:03 EST
Shouldn't this bug warrant an errata patch?  There will be tons of
people using nano on GNOME on FC3 with gnome-terminal who will hit
this problem.  The fact that 2 duplicates of this report already are
in bugzilla indicates how severe this will be.
Comment 13 Robert 'Bob' Jensen 2004-12-07 13:14:59 EST
I just upgrade vte to vte-11.11-15.i386 from rawhide and the problem
continues.
Comment 14 Sean Carolan 2005-01-05 15:47:23 EST
>Shouldn't this bug warrant an errata patch?  There will be tons of
>people using nano on GNOME on FC3 with gnome-terminal who will hit
>this problem.  The fact that 2 duplicates of this report already are
>in bugzilla indicates how severe this will be.

Agreed, this problem started affecting me right after upgrading to FC3
from FC2.  Huge problem for newbies who aren't familiar with vi or
other text editors, and depend on nano to set up their boxes.  Please
fix asap!
Comment 15 CaMiX 2005-01-11 17:45:24 EST
Yes a fix for this would really be appreciated.  Just noticed this
problem after installing Fedora 3 core and then updating it.  I'm new
to Fedora and was wondering how to get vte upgrade off of rawhide. 
Tried going to ftp.redhat.com:/pub/rawhide but that dir doesn't exist
anymore.  Needed some help with getting vte-0.11.11-13 installed
(using yum would be nice) to fix this.  Only see 0.11.11-6 when doing
a 'yum search vte', which is what I have installed.
Comment 16 Trevor Cordes 2005-01-12 08:17:34 EST
My temp solution, without requiring rawhide is to put these in system
files:

csh users:
/etc/csh.login
setenv TERM linux

b*sh users:
/etc/profile
export TERM=linux
Comment 17 Todd Epple 2005-03-09 11:47:23 EST
I am facing the exact same problem with my new fresh clean install of 
RHEL4 so the fixed vte hasn't made it into RHEL4 yet.  It was very 
annoying and I certainly didn't want to change my termtype to linux 
(although doing so fixes the problem).

I looked at upgrading to the newest development version of vte on the 
fedora development site (0.11.12-1) but found that it requires the 
new 2.4 version of Python to be installed.

So I found vte 0.11.11-15.i386.rpm through Googling, installed it, 
and now I'm as good as gold.  I'm not sure if it had any bad side 
effects with other programs but "nano" works great now!  It will be a 
bummer to manually install this package with new boxes so it would be 
nice if RH bundles it in an up2date sometime soon.  Thanks!
Comment 18 dStruct 2005-03-10 07:57:29 EST
My Fedora Core 3 (2.6.10-1.766_FC3) workaround..

# /etc/bashrc

# System wide functions and aliases
# Environment stuff goes in /etc/profile

# by default, we want this to get set.
# Even for non-interactive, non-login shells.
if [ "`id -gn`" = "`id -un`" -a `id -u` -gt 99 ]; then
	umask 002
else
	umask 022
fi

# gnome-terminal workaround for nano scrolling
export TERM=linux

# are we an interactive shell?
if [ "$PS1" ]; then
    case $TERM in
	xterm*)
		if [ -e /etc/sysconfig/bash-prompt-xterm ]; then
			PROMPT_COMMAND=/etc/sysconfig/bash-prompt-xterm
		else
	    	PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/~}\007"'
		fi
		;;
	screen)
		if [ -e /etc/sysconfig/bash-prompt-screen ]; then
			PROMPT_COMMAND=/etc/sysconfig/bash-prompt-screen
		else
		PROMPT_COMMAND='echo -ne "\033_${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/~}\033\\"'
		fi
		;;
	*)
		[ -e /etc/sysconfig/bash-prompt-default ] &&
PROMPT_COMMAND=/etc/sysconfig/bash-prompt-default
	    ;;
    esac
    # Turn on checkwinsize
    shopt -s checkwinsize
    [ "$PS1" = "\\s-\\v\\\$ " ] && PS1="[\u@\h \W]\\$ "
    
    if ! shopt -q login_shell ; then # We're not a login shell
        for i in /etc/profile.d/*.sh; do
	    if [ -r "$i" ]; then
	        . $i
	    fi
	done
	unset i
    fi
fi
# vim:ts=4:sw=4
Comment 19 dStruct 2005-03-10 09:02:27 EST
I actually found the workaround posted above effects the prompt when multiple
tabs are open in gnome-terminal, to fix this simply move the workaround lines
from line 14 to line 21, to read as follows:

if [ "$PS1" ]; then
    case $TERM in
        xterm*)
                if [ -e /etc/sysconfig/bash-prompt-xterm ]; then
                        PROMPT_COMMAND=/etc/sysconfig/bash-prompt-xterm
                else
                PROMPT_COMMAND='echo -ne
"\033]0;${USER}@${HOSTNAME%%.*}:${PWD/#$HOME/~}\007"'
                # gnome-terminal workaround for nano scrolling
                export TERM=linux
                fi
Comment 20 Alex Tribble 2005-04-02 03:50:06 EST
For FC3 users, rebuilding vte-0.11.12-1 from development on an FC3 host will fix
your problems, and remove the python-2.4 dependency. For your convenience, I've
set up a YUM repo at:

http://prat.homelinux.net/~prat/yumrepo/

And changed the version to vte-0.11.12-1.fc3. Seems to be working fine over
here, YMMV.

(You could also just type rpmbuild --rebuild vte-0.11.12-1.src.rpm and install
the resulting package from /usr/src/redhat/RPMS)
Comment 21 Gregory Harris 2005-04-13 10:41:14 EDT
I've been working with both FC3 and EL4 on this.  Neither vte-0.11.11-15 nor
vte-0.11.12-1 from rawhide fix this problem completely.  Yes it will work with
nano, but other programs, such as "ispell" break.
Comment 22 Warren Togami 2005-09-11 06:29:47 EDT
This is fixed in newer FC updates.  ispell is another issue probably in Bug
#141324.  If you want this fixed in RHEL4 then you should file it in
IssueTracker and escalate the issue through the support department.
Comment 23 John Thacker 2006-10-30 16:42:35 EST
*** Bug 138726 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.