Bug 1279955 - Clusters with no management network after upgrade
Clusters with no management network after upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity urgent
: ovirt-3.6.1
: 3.6.1
Assigned To: Yevgeny Zaspitsky
Michael Burman
:
: 1284584 (view as bug list)
Depends On:
Blocks: RHEV_36_HTB RHEV3.6Upgrade 1372955
  Show dependency treegraph
 
Reported: 2015-11-10 10:13 EST by Yevgeny Zaspitsky
Modified: 2016-09-04 06:18 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1372955 (view as bug list)
Environment:
Last Closed: 2016-04-19 21:33:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48376 master MERGED engine: Set management network in upgrade Never
oVirt gerrit 48740 ovirt-engine-3.6 MERGED engine: Set management network in upgrade Never
oVirt gerrit 48778 ovirt-engine-3.6.1 MERGED engine: Set management network in upgrade Never

  None (edit)
Description Yevgeny Zaspitsky 2015-11-10 10:13:32 EST
Description of problem:
Clusters with no management network after upgrade

Version-Release number of selected component (if applicable):
rhev-m 3.6.0-3

How reproducible:
100%

Steps to Reproduce:
1. In v3.5 create a cluster with a host in it
2. Upgrade to 3.6
3.

Actual results:
The cluster appears with no management network

Expected results:
rhevm network should be the management network

Additional info:
Other side effects:
1. Setup networks dialog keep loading endlessly
2. In create new VM dialog vNIC profile list is empty
Comment 1 Eyal Edri 2015-11-10 14:07:00 EST
since we target beta2 build to support upgrades, this is a blocker.
proposing flag.
Comment 3 Michael Burman 2015-11-24 09:30:33 EST
Hi Yevgeny,

Just finished upgrade from rhevm-3.5.6.2-0.1.el6ev.noarch to rhevm-3.6.0.3-0.1.el6.noarch
And i just want to be sure is this BZ^^ going to fix all the next issues or additional bugs required:

- No management network for clusters after upgrade
- Setup Networks dialog keep loading forever
- vNIC profile list is empty for new vNICs for existing VMs, exist ones and for new VMs.
- The default management network for new 3.6 DCs and clusters is 'rhevm'.

Thanks,
Comment 4 Yevgeny Zaspitsky 2015-11-25 02:58:04 EST
(In reply to Michael Burman from comment #3)
> Hi Yevgeny,
> 
> Just finished upgrade from rhevm-3.5.6.2-0.1.el6ev.noarch to
> rhevm-3.6.0.3-0.1.el6.noarch
> And i just want to be sure is this BZ^^ going to fix all the next issues or
> additional bugs required:
> 
> - No management network for clusters after upgrade
> - Setup Networks dialog keep loading forever
> - vNIC profile list is empty for new vNICs for existing VMs, exist ones and
> for new VMs.
Yes, those would be fixed.

> - The default management network for new 3.6 DCs and clusters is 'rhevm'.
The default management network will continue being 'rhevm' for an existing installation and 'ovirtmgmt' for a new installation (as designed).
> 
> Thanks,
Comment 5 Michael Burman 2015-11-25 03:26:21 EST
What do you mean by new installation?

To be more clear -->
After upgrade from 3.5.z to 3.6.0, when creating new 3.6 DC/Cluster in the upgraded engine, i get as default 'rhevm' and not 'ovirtmgmt' network.
It is a bug, the question is, if it will be fixed as part of this one^^ and are you aware of this bug?
Thanks,
Comment 6 Yevgeny Zaspitsky 2015-11-25 06:12:01 EST
AFAIK that isn't a bug, but a desired behavior.
Anyhow that is not related to this bug nor to mgmt network per cluster feature.
Comment 7 Jiri Belka 2015-11-26 04:53:30 EST
works for me with 3.6.1-0.2.el6.noarch, see https://bugzilla.redhat.com/show_bug.cgi?id=1285309#c3
Comment 8 Michael Burman 2015-11-26 05:08:28 EST
Verified on - 3.6.1-0.2.el6
Comment 9 Dan Kenigsberg 2015-12-10 09:56:58 EST
*** Bug 1284584 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.