Bug 1280035 - middle mouse button not working anymore
middle mouse button not working anymore
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libinput (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
: 1280039 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 14:33 EST by Ali Akcaagac
Modified: 2015-11-10 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1280039 (view as bug list)
Environment:
Last Closed: 2015-11-10 17:06:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
evemu-record (19.22 KB, text/plain)
2015-11-10 16:51 EST, Ali Akcaagac
no flags Details
libinput-debug-events (12.00 KB, text/plain)
2015-11-10 16:51 EST, Ali Akcaagac
no flags Details
libinput-list-devices (3.09 KB, text/plain)
2015-11-10 16:52 EST, Ali Akcaagac
no flags Details

  None (edit)
Description Ali Akcaagac 2015-11-10 14:33:04 EST
Running Fedora 22 here and have following issue.

When I installed Fedora 22 (1-2 Weeks after release) the middle mouse pointer was able to copy and paste text from e.g. terminal to e.g. browser or other fields where I can paste test.

Since a couple of weeks (maybe 1-2 months ?) this is not working anymore. Copy and paste using middle mouse doesn't work anymore. I have to use right mouse copy and in the target right mouse and paste.

This is highly annoying and I would like to have middle mouse copy and paste re-enabled again.

I used google to look at similar issues and found that this might be related to libinput ...
Comment 1 Peter Hutterer 2015-11-10 16:36:22 EST
run sudo libinput-debug-event and monitor its output. do you see the middle button events get through here?

What type of device are we talking about here, a normal mouse? Can you record a middle click with evemu-record and attach the log here?
Comment 2 Ali Akcaagac 2015-11-10 16:50:55 EST
Ok I had to install evemu to get that record thingy working. Strangely, after dealing around with the tools libinput-debug-event and evemu-record the middle mouse does copy&paste again while it didn't for a couple of months. Somehow playing with these tools might have triggered (or activated) something ?
Comment 3 Ali Akcaagac 2015-11-10 16:51 EST
Created attachment 1092477 [details]
evemu-record
Comment 4 Ali Akcaagac 2015-11-10 16:51 EST
Created attachment 1092478 [details]
libinput-debug-events
Comment 5 Ali Akcaagac 2015-11-10 16:52 EST
Created attachment 1092479 [details]
libinput-list-devices
Comment 6 Peter Hutterer 2015-11-10 17:06:40 EST
I don't know how they could, running either of these tools are completely independent of the rest of the desktop stack and don't change anything elsewhere. Both logs show up middle button presses, and if it works again now I'm unsure how to proceed now. 

I'm closing this as WORKSFORME for now, if it comes back please re-open.
Comment 7 Peter Hutterer 2015-11-10 17:13:39 EST
*** Bug 1280039 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.