Bug 1280093 - RFE: support async storage events
RFE: support async storage events
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-10 17:47 EST by Cole Robinson
Modified: 2017-03-05 13:21 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-05 13:21:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2015-11-10 17:47:18 EST
There's lots of misc issues that have been reported WRT virt-manager and its cached data about available storage pools and volumes. Users created VMs or storage volumes outside of running virt-manager, and the UI isn't updated to see those files.

The proper fix here is to use storage event APIs like we do with network and domain objects. Unfortunately these libvirt APIs don't exist yet. The RFE is here:

https://bugzilla.redhat.com/show_bug.cgi?id=636027

I'm opening this so we can dupe various bugs here that won't be properly fixed until there's event support.
Comment 1 Cole Robinson 2015-11-10 17:50:00 EST
*** Bug 1251400 has been marked as a duplicate of this bug. ***
Comment 2 Cole Robinson 2017-03-05 13:21:32 EST
Support for this has been upstream for over 6 months now

Note You need to log in before you can comment on or make changes to this bug.