Bug 1280169
| Summary: | Can not restart node service on atomic host | ||
|---|---|---|---|
| Product: | OpenShift Container Platform | Reporter: | Ma xiaoqiang <xiama> |
| Component: | Installer | Assignee: | Scott Dodson <sdodson> |
| Status: | CLOSED ERRATA | QA Contact: | Ma xiaoqiang <xiama> |
| Severity: | medium | Docs Contact: | |
| Priority: | high | ||
| Version: | 3.1.0 | CC: | aos-bugs, bleanhar, cryan, jokerman, mmccomas, xiama, xtian |
| Target Milestone: | --- | Keywords: | TestBlocker, UpcomingRelease |
| Target Release: | --- | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | Bug Fix | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2016-01-27 19:42:42 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1286936 | ||
| Bug Blocks: | |||
|
Description
Ma xiaoqiang
2015-11-11 05:16:42 UTC
Ok, done with the work now. https://github.com/openshift/origin/pull/6022 rcm-img-docker01.build.eng.bos.redhat.com:5001/openshift3/node 50db2d604ea6 Check on puddle [3.1/2015-12-02.3]
# openshift version
openshift v3.1.0.4-3-ga6353c7
kubernetes v1.1.0-origin-1107-g4c8e6f4
etcd 2.1.2
# service atomic-openshift-node restart
Redirecting to /bin/systemctl restart atomic-openshift-node.service
Job for atomic-openshift-node.service failed because the control process exited with error code. See "systemctl status atomic-openshift-node.service" and "journalctl -xe" for details.
# systemctl status atomic-openshift-node.service
● atomic-openshift-node.service
Loaded: loaded (/etc/systemd/system/atomic-openshift-node.service; enabled; vendor preset: disabled)
Active: activating (start-post) (Result: exit-code) since Fri 2015-12-04 11:19:15 CST; 7s ago
Process: 12298 ExecStop=/usr/bin/docker stop atomic-openshift-node (code=exited, status=1/FAILURE)
Process: 12313 ExecStart=/usr/bin/docker run --name atomic-openshift-node --rm --privileged --net=host --pid=host -v /:/rootfs:ro -e CONFIG_FILE=${CONFIG_FILE} -e OPTIONS=${OPTIONS} -e HOST=/rootfs -e HOST_ETC=/host-etc -v /var/lib/origin:/var/lib/origin -v /etc/origin/node:/etc/origin/node -v /etc/localtime:/etc/localtime:ro -v /etc/machine-id:/etc/machine-id:ro -v /run:/run -v /sys:/sys:ro -v /usr/bin/docker:/usr/bin/docker:ro -v /var/lib/docker:/var/lib/docker -v /lib/modules:/lib/modules -v /etc/origin/openvswitch:/etc/openvswitch -v /etc/origin/sdn:/etc/openshift-sdn -v /etc/systemd/system:/host-etc/systemd/system openshift3/node (code=exited, status=1/FAILURE)
Process: 12305 ExecStartPre=/usr/bin/docker rm -f atomic-openshift-node (code=exited, status=1/FAILURE)
Main PID: 12313 (code=exited, status=1/FAILURE); : 12314 (sleep)
Memory: 88.0K
CGroup: /system.slice/atomic-openshift-node.service
└─control
└─12314 /usr/bin/sleep 10
Dec 04 11:19:15 openshift-154.lab.eng.nay.redhat.com systemd[1]: Starting atomic-openshift-node.service...
Dec 04 11:19:17 openshift-154.lab.eng.nay.redhat.com docker[12305]: Error response from daemon: Cannot destroy container atomic-openshift-node: Could not kill running container, cannot remove - [2...er destroyed
Dec 04 11:19:17 openshift-154.lab.eng.nay.redhat.com docker[12305]: Error: failed to remove containers: [atomic-openshift-node]
Dec 04 11:19:17 openshift-154.lab.eng.nay.redhat.com docker[12313]: Error response from daemon: Conflict. The name "atomic-openshift-node" is already in use by container f000050552de. You have to ...e that name.
Dec 04 11:19:17 openshift-154.lab.eng.nay.redhat.com systemd[1]: atomic-openshift-node.service: main process exited, code=exited, status=1/FAILURE
Hint: Some lines were ellipsized, use -l to show in full.
Still can not restart the node service
This is fixed by ensuring you've updated the node image. I've rebuilt the node image for some other changes so please make sure you're running this image : rcm-img-docker01.build.eng.bos.redhat.com:5001/openshift3/node 8923200e3c44 if you're still having troubles I need to know the image id you're using check against 8923200e3c44, restart the node service successfully. Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2016:0075 |