Bug 1286936 - Can not create master certificates when installing env on Atomic host
Can not create master certificates when installing env on Atomic host
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Scott Dodson
Ma xiaoqiang
: TestBlocker
Depends On:
Blocks: 1280169
  Show dependency treegraph
 
Reported: 2015-12-01 01:39 EST by Ma xiaoqiang
Modified: 2016-07-03 20:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:42:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2015-12-01 01:39:54 EST
Description of problem:
Can not create master certificates when installing env on Atomic host

Version-Release number of selected component (if applicable):
https://github.com/sdodson/openshift-ansible containers

How reproducible:
Always


Steps to Reproduce:

1. Install env on Atomic host
#ansible-playbook -i hosts  containers/playbooks/byo/config.yml  -v


Actual results:
TASK: [openshift_master_ca | Create the master certificates if they do not already exist] *** 
failed: [10.66.79.126] => {"cmd": "oadm create-master-certs --hostnames=10.66.79.126,kubernetes.default,kubernetes,openshift.default.svc,openshift.default,openshift-126.lab.eng.nay.redhat.com,192.168.0.105,172.30.0.1,openshift.default.svc.cluster.local,kubernetes.default.svc,kubernetes.default.svc.cluster.local,openshift --master=https://openshift-126.lab.eng.nay.redhat.com:8443 --public-master=https://openshift-126.lab.eng.nay.redhat.com:8443 --cert-dir=/etc/origin/master --overwrite=false", "failed": true, "rc": 2}
msg: [Errno 2] No such file or directory

FATAL: all hosts have already failed -- aborting

Expected results:
Install env successfully

Additional info:
Comment 1 Scott Dodson 2015-12-02 12:02:15 EST
containers branch has been updated to add openshift_cli dependency to openshift_master_ca role ensuring that oadm is installed before attempting to create certs.

commit: https://github.com/openshift/openshift-ansible/commit/83c050745cd9bcbac2202b0e685c0e71cbeb29fa
Comment 2 Ma xiaoqiang 2015-12-02 22:02:19 EST
check again

TASK: [openshift_master_ca | Install the base package for admin tooling] ****** 
failed: [10.66.79.148] => {"cmd": "/usr/bin/yum -d 2 -y install atomic-openshift", "failed": true, "rc": 2}
msg: [Errno 2] No such file or directory

FATAL: all hosts have already failed -- aborting

User have no permission to install package on Atomic host.
Comment 3 Scott Dodson 2015-12-03 10:01:13 EST
Ma,

Can you post your hosts file and the output of the following? The task you've listed should be skipped for containerized installs so I wonder if somehow the facts are getting set wrong?

ansible-playbook -i /path/to/inventory playbooks/byo/openshift_facts.yml

Also, lets check that you're on the right commit?
git describe  from your openshift-ansible checkout
Comment 7 errata-xmlrpc 2016-01-27 14:42:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0075

Note You need to log in before you can comment on or make changes to this bug.