Bug 1280180 - Failed to switch Hosted Engine maintenance level to global via Hosted Engine TUI
Failed to switch Hosted Engine maintenance level to global via Hosted Engine TUI
Status: CLOSED DUPLICATE of bug 1280183
Product: ovirt-node
Classification: oVirt
Component: legacy-ovirt-node-plugin-hosted-engine (Show other bugs)
3.6
Unspecified Unspecified
high Severity medium (vote)
: ovirt-3.6.1
: ---
Assigned To: Ryan Barry
Huijuan Zhao
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-11 01:12 EST by Huijuan Zhao
Modified: 2016-02-10 14:18 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-18 12:48:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
fdeutsch: ovirt‑3.6.z?
fdeutsch: ovirt‑4.0.0?
rule-engine: planning_ack?
fdeutsch: devel_ack+
rule-engine: testing_ack?


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48468 master MERGED The maintenance dialog should reflect the current setting Never

  None (edit)
Description Huijuan Zhao 2015-11-11 01:12:58 EST
Description:.
Failed to switch Hosted Engine maintenance to Local and None via Hosted Engine TUI

Version:
ovirt-node-plugin-hosted-engine-0.3.0-2.el7ev.noarch
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20151104.0.el7ev)

Test Steps:
1. RHEV-H installed successful.
2. Login RHEV-H, change to Hosted Engine page, Deploy Hosted Engine.
3. Click <Set Hosted Engine maintenance> on Hosted Engine page
4. Choose and enable Local level, click < Set >, and click <Set Hosted Engine maintenance> to check.
5. Choose and enable None level, click < Set >, and click <Set Hosted Engine maintenance> to check.

Actual Results
After step4, set Local Maintenance Level failed, it is still Global Maintenance Level.
After step5, set None Maintenance Level failed, it is still Global Maintenance Level.

Expected Results
After step4, set Local Maintenance Level successful, it should be Local Maintenance Level.
After step5, set None Maintenance Level successful, it should be None Maintenance Level.
Comment 1 Red Hat Bugzilla Rules Engine 2015-11-11 03:25:09 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Ryan Barry 2015-11-11 13:02:09 EST
The TUI does not reflect the current state of maintenance -- the "Set Hosted Engine Maintenance" dialog defaults to selecting "global", but dropping to a shell and checking "hosted-engine --vm-status" or the "Hosted Engine VM Status" in the TUI will reflect the maintenance level.

At present, the bug description reflects the opposite case. I forgot that the TUI will not consider the default selection unless it's changed off of, so setting to "global" will not work unless another option is selected, then global re-selected, but "local" and "none" work normally (as can be verified on the console or the TUI)

I submitted a patch which turns this into an RFE, and the dialog will now default to whatever the current setting is.

Note for verification that it takes ovirt-hosted-engine-ha a couple of seconds to reflect the change, even after the TUI returns.
Comment 3 Ryan Barry 2015-11-17 09:23:53 EST
*** Bug 1280183 has been marked as a duplicate of this bug. ***
Comment 4 Ryan Barry 2015-11-18 12:48:12 EST

*** This bug has been marked as a duplicate of bug 1280183 ***

Note You need to log in before you can comment on or make changes to this bug.